Help! installer won't install on windows 7


I just signed up for Roon and downloaded the installer but it won’t install. I just get a Roon popup. “Roon requires Windows 7 or Higher”.
I’m running Windows 7 64 bit.

This guy had the same problem:

Any help would be much appreciated.


Hi James,

It looks like Joe_de_Jesus never got back to Mike, so we don’t know what the root cause was in that case.

Your screen shot looks good and PC is a good spec. I’m leaving a flag for @Mike, @Support to follow this up with you.

PS I reinstalled Roon on Windows 7 PC only two days ago so I know it does work,
PPS Just in case do try rebooting the PC and trying again.

Are you installing the 64 or 32 bit version? And if one is not working you might try the other.

Thanks for responding.

I tried the 32 bit installer and got the same problem.

Rebooting hasn’t helped either.

Are the Service Packs a point of distinction between James and Carl’s experience ?

Handy Update installer here.

Thanks andybob,

update installed but no change.

Hi @James_Weston ---- Thank you for the report and my apologies for troubles. I wanted to follow up with you because we have tested the Windows 7 update installer in house and are running without issue.

We will continue investigating this issue and have scheduled a meeting with our developers to discuss. I will follow up with you once we have some more feedback. We greatly appreciate your patience!


Hi Eric,

Thanks for the support.

It’s a baffling problem. The only cause that I can think of is a failed Windows 10 installation months ago. But I haven’t had any other system problems whatsoever.

Hi @James_Weston ----- I wanted to touch base with you, because as mentioned I had a chance to touch base with my developers and in order to further our investigation into this issue we would like to confirm what version of Windows 7 you are running.

I did a bit of research on how to confirm this information and have found steps on how to do so, which can be found here.


Thanks Eric,

Good Luck!

1 Like

Hi @James_Weston ---- Thank you for following up and confirming that information for me! Very appreciated!


Hi @James_Weston — I wanted to touch base with you as I have been doing a bit of research into this issue you are experiencing. I came across this article on Microsoft’s website if you’d like to check out the proposed troubleshooting steps for dealing with an NSIS error.

This maybe a silly question and my apologies for any confusion on my part, but have you tried to re-download the installer.


Thanks Eric.

I had already tried redownloading the installer several times. But I went through all of the NSIS troubleshooting steps and got nowhere.

Interestingly, running the installer as administrator produces a different error message.

  • James

@James_Weston ----- Thank you for the follow up and the feedback. This most recent observation is indeed interesting. Does “task manager” show any roon processes running while in this state?


Only the Roon setup window itself.

try rebooting and then rerunning the installer as admin

Thanks Danny,

Unfortunately, it didn’t work.

you are getting same thing about quitting all instances? that check is looking to see if Roon.exe is running, that’s it.

as for the win7 thing, it’s a check for win7 from our installer pkg… ive never seen this fail other than the 2 cases noted in this thread. it probably is checking for registry keys.

Yeah, same message.

Wait, I got it to work.

Redownloaded a new 32 bit installer direct to desktop. Got the same windows 7 error. But when I ran it as administrator it just worked.
Redownloaded a new 64 bit installer and the same thing happened.

I did just install some new Windows updates. I don’t know whether that had any effect.

Problem solved. Thanks for the support guys.

1 Like