Help installing ROCK

I did that several times now. Used the etcher application:(

@Dylan_van_Druten How big is the USB stick? Try to use something in the 4-8GB size if you can not something like 128GB

Tagging @support for you too

I have a 16GB USB, that isn’t too big is it?

should be ok…do you have a different one to try? Seem to recall I had to try a couple before I found one the BIOS update liked.

I tried an other stick which is 64GB, can’t find another one. I there a recommened brand? I use sandisk

sandisk should be ok. It is possible there is a corrupt image from roon side…I think that happened once before, but the support guys will chime in shortly no doubt.

I probably do something wrong… I unchecked the Uefi boot and Legacy is on.

A thing i see is that the m2 slot is not populated. The latest BIOS is installed…

its been a while since I installed ROCK…over a year at least so I am a bit rusty on the process and files etc but if you are following the KB docs it should be pretty well documented here

did you put an M.2 board in there? if so then thats a problem unless you are installing to a SATA SSD 2.5" drive

Pardon? I thought that you had to have an M.2 SSD installed for the OS. ROCK expects to find one there to use. This could be the issue.

there is a M2 ssd installed. I did folloy the complete guide… now trying to fix the bios thing

I would open up and refit the M.2 card again. sometimes the contacts can oxidise and a couple of plugging in and out will wipe them sufficiently to get things working.

also check the card is compatible…

Wasn’t there something about NVMe SSDs not being recognised in older generation NUCs?

Have you tried a different USB socket - one on the front?

Does the BIOS recognise the M2. SSD?

in the Boot menu i see the ssd i tried all the inputs

Is the RAM recognised in the BIOS?

A list of the components you are using would be good along with a link to the ROCK image you downloaded. What else is plugged in?

I installed ROCK for the first time before Christmas and the after enabling legacy boot and putting the USB stick in a front socket it all worked perfectly.

Could it be something daft and the blank screen be an monitor issue? Unsupported resolution?

5th gen NUCs and NVMe SSDs can be an issue:

problem solved, had to do with the resolution pffff
thanks all!!

2 posts were split to a new topic: Help Installing ROCK on a Azulle i5 Kaby Lake Mini PC