Help! - Music streaming keeps skipping

Hi Roon Team,

I have Roon running on a new mac mini with SSD and wired ethernet with internet access via media rack that has 1G fiber connection. The mac mini is connected to my Qutest DAC via USB which is connected directly to my speakers.

Most of the time I start streaming from TIDAL, the music plays, but constantly drops out with a short “skip” or “drop-out” every 5-10 seconds. I don’t have this

Would you pls help me fix this? As you can imagine, it absolutely RUINS the music listening experience.

Thanks… Chris

I’ve moved your topic to the support section of the forum.
In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Ok, thanks. How do I track the topic now?

Do I need to provide more setup info than I did?

Should I wait for the reply to see what they specifically need?

If you have details of your network equipment that would help the support team. Make and model.
I’m just a user like you.

Hi @Chris_Cook1,

Can you please let us know the model/manufacturer of all your networking gear?
Does this issue occur on multiple zones or just one zone in particular?
Can you please try to use “System Output” zone (PC’s speakers) and check for the issue there?

Hi Noris,

Let me outline my system setup as follows, starting with the internet connection:
1G AT&T Fiber connected to Motorola Gateway BGW210-700 connected to UniFi Switch PRO 24 PoE connected to Mac mini 2019 connected to Qutest DAC connected to KEF R11 speakers.

I only have one system output zone streaming digital music.

While you’re waiting for an official response from Support, you might want to connect your Mac Mini directly to your router. I think that some switches have caused issues in the past.

Thanks for the quick reply, GKern. I will try that.

Do you know why a high-performance switch able to handle 4K video with no issue would have problems streaming audio? As an engineer, it seems strange to me.

I have no idea whatsoever (I am very much not an engineer), but you have fairly simple set-up generally, and so it is really about eliminating whatever might be causing your issues. Even if this step doesn’t do anything, at least we know the switch isn’t the problem (and it seemed like it would be a fairly easy thing to try)!

As an example managed switches sometimes do igmp snooping but not fully to standards, so roon fails.

Hi @Chris_Cook1,

I too would suggest getting the managed switch out of the equation as a first step. Managed switches have worked with Roon in the past, but we’ve seen the need to change the factory default settings to get them to work, so if we can narrow down the issue to just the switch, we would be in a much better position to look for the solution.

Our Networking Best Practices Guide also provides some great information regarding managed switches:

Managed Switches

Managed switches can be very robust, but they are often designed for professional installation, so in many cases the out-of-box configuration is not right. If your switch has a “flow control” setting, please make sure that it is enabled. Also, make sure that the switch is not performing any sort of throttling that might impact communication between cores, storage, remotes, and/or audio endpoints. Finally, ensure that the switch is configured to pass multicast and broadcast traffic. If in doubt about any of this, try temporarily replacing your managed switch with a “dumb” switch to see if things improve.

Hi everyone,

Thanks for the inputs on this issue. I took the recommended shortcut and simply connected the ethernet cable directly to the router. Everything is working great now!

Would be nice if Roon could post a more straight-forward guide on tips for connecting/configuring switches.

Thanks again for the inputs… Chris


Hi @Chris_Cook1,

Thanks for letting us know that bypassing the switch resolved the issue here! Yes, managed switches are trickier to get working properly with Roon, so we suggest using un-managed switches whenever a network switch is needed in a Roon setup. If you run into any other issues, just let us know!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.