Help! My Roon app is no longer working and my music has disappeared

Roon Server Machine

Mac OS 13.5.2
Roon Server is a Weiss 502 DAC
Problem is that my Roon server appears to have been corrupted. It’s stuck on a single track from a single artist. When I click play, nothing happens. The play button isn’t even clickable. When I try and go to the home screen to search for artists or songs, they’re no longer there. It says “0 of 214 artists” and my tracks don’t show up at all. It’s like everything was deleted. Everything worked fine when I left my office on Wednesday last week. When I returned, that’s when I discovered the problems.

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Have you rebooted everything? That is usually the first step I do if something gets weird.

I rebooted the DAC / Server. But nothing else. I unplugged it for a few mins and then plugged it back in. That didn’t seem to help. Is there anything else I should unplug?

@William_Bly, a few questions:

  1. Is your Weiss DAC your Roon Server, or is it the Mac running 13.5.2? It appears the Weiss is a DAC/network streamer and Roon Ready endpoint, not a Roon Server computer.
  2. Have you confirmed that your Roon Server computer is working on your network? Have you rebooted it?

Just to add to both Moderators; what Roon Remote are you you using?

iPhone
iPad
Android tablet/phone

I’m sorry folks. I get the terminology confused. The the Weiss is a roon ready endpoint. The roon server is on the Mac. I’m getting ready to head home from the office, so I’ll reboot the computer and see if that helps.

Looks like rebooting my computer worked! TY for the suggestions.

1 Like

Glad you are back in business William!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.