Help needed with login issue

Hi Folks, help needed.

This week I have got my new Mac Pro up and running. I used an application called “migration assistant” in osx which transfers all the files and folder from my old mac to the new one.

However when I open roon and log in the app just says “logging in” and goes no further.

I have tried downloading roon again but same as above.

Have emailed roon support 2 days ago, no reply as yet.

Running osx Catalina 10.15.4

Endpoints Meridian 861v8 and 818v3

If I use the old meridian Sooloos app on my phone it can see both the meridian zones, all connected on hard wired ethernet.

Any thoughts ?


You’ll need to restore a Roon backup as Time Machine does not reliably backup databases. Go to Settings > Backups and under Find Backups click on Browse to locate your last backup and Restore.

Hi Martin, thanks for your reply. I’m afraid I never backed up roon, but am happy to start again with a clean install on my new mac, but I can’t get past the login page

Hi @Andrew_Moran,

As @Martin_Webster noted, using Time Machine can cause issues when transferring the live database, as mentioned in our Backup documentation. I would suggest you install Roon fresh by using these instructions:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App to generate a new Roon database folder

First, close Roon completely.

Your Roon databases and settings are located in the /Users/USERNAME/Library/Roon folder. To go there follow these steps:

  1. Open Finder and click Go in the menu bar
  2. Hold down the alt key to show the Library folder
  3. Click the Library folder
  4. Find and rename the Roon folder

Now restart Roon and you should be good to go. If this works you can go back and delete the folder you renamed.

I recommend you routinely make a backup of the database. :slightly_smiling_face:

Edit: Oh, I see @noris beat me to it!

1 Like

Hi Noris, thanks for your reply.

I have followed your instructions, it then defaults to the “choose your roon core” page and I select “set up a roon core on this mac”

This then takes me to the login page, where I enter my email and password then I get “logging in” icon and I get no further.

However if I click off the “logging in “icon, it comes up with “Add your music” and it displays the folders I have selected for it to look at which are correct.

The we move onto the “add a music service” page and I click no thanks.

We then move onto “set up your audio devices” page but roon sees nothing, I then click finish and it says “no audio devices found”

Then the roon logo appears flashing and nothing happ

is this an issue with catalina 10.15.4 , I rebooted the old mac earlier which was running 10.15.3 and I could login as usual, is this a security issue in the osx update ??

Hi @Andrew_Moran,

It sounds like there’s a firewall or antivirus application blocking Roon from working properly on your Catalina Mac. I would use these instructions to make sure that you have added Roon and RAATServer as exceptions to your MacOS firewall and try temporarily disabling any other firewall application you may have (McAFee/Bullguard/Little Snitch to provide a few examples).

Hi Noris, I have tried your suggestion, and it makes no difference.

However this morning I connected one of my older macbook pro’s which is still running Catalina 10.15.3 to the ethernet on a hard connection. Downloaded roon, and I could login as normal , asked if I wanted to use this mac as a core, I said yes, which then instructed me to deauthorize my mac pro which I did and then took me to the page that asks for which folders to look at.

So nothing to down with my systems or settings, only difference is the new mac pro is running 10.15.4 which points to a roon issue.


Hi Noris , a further update.

I have now downloaded roon on my other macbook pro which is running Catalina 10.15.4, no problems, it all functions perfectly and displays the two Meridian endpoints, so it seems the upgrade to 10.15.4 is not an issue.

Same problem logging in on new macpro however, if you click of “logging in” icon it then it asks to select core which I have running on the mac book pro and then it works as usual, but if I try and change the core on the new mac pro (to make it the core) , again it does not see the meridian endpoints.

I’m wondering if the problems lies with the hardware, I know there has been some issues with the T2 chip ?

Hardware details

Mac pro 3.3GHZ 12-Core Intel Xeon W running Catalina 10.15.4

Macbook pro 2.6GHz 6-core Intel Core i7 running Catalina 10.15.4


Hi @Andrew_Moran,

Can you please send me a copy of your Roon logs from the Mac that you mentioned with this issue?

You can access Roon logs by using these instructions and the best way to get them over to me would be via a shared Dropbox / Google Drive / link.

i think you should have them now ?

Hi @Andrew_Moran,

Thanks for sending the logs over. I am seeing signs of corruption in the logs you sent, it looks like parts of the database are missing. Is this the same database that you have previously set aside using my above instructions?

Hi Noris, I have re installed roon and navigated to the library folder. There is no roon folder in there.

Hi @Andrew_Moran,

According to the logs you sent, Roon should be installed under /Users/andrewjmoran/Library/Roon/. If you cannot locate the Roon folder there, you may need to enable show hidden files and folders on Mac:

Can you confirm you are able to rename the old Roon database using thoses instructions and install it fresh?

Hi Noris, let me try and explain where I am

After your first reply about the changing the Roon folder to Roon_old, I did that, this folder was under my “music” folder in finder.

Since that point I have deleted the “Roon_old” folder

Currently I can see no Roon folder if I open up the music folder in finder after re-installing Roon.

I have re-installed Roon around six times but it never get past the logging in page, unless I click of the “logging in” icon and then I can access Roon, I then ask it to use this mac as a core but Roon cannot find any audio sources.

I then went to your link /Users/andrewjmoran/Library/Roon/

I can see five folders







Hi @Andrew_Moran,

I don’t understand why you deleted the Roon folder from your music directory, what was in that folder? The database should have be inside the /Users/andrewjmoran/Library folder as the instructions mentioned. Maybe you deleted some music files you had set aside for Roon?

So just to clarify here, you never renamed the /Users/andrewjmoran/Library/Roon to /Users/andrewjmoran/Library/Roon_old? If you haven’t, this is what you will have to do to start Roon with a fresh database.

Hi Noris

I did actually rename the Roon file to Roon_old, but then I deleted it as I thought a new install would sort that out, that seems to have been the wrong thing to do.

It had a few music tracks in it that I had used during the time that Roon could not see any external storage after the Catalina upgrade, my actual music library is on an external G drive connected by thunderbolt.

However my time capsule is still making backups so I can go restore the Roon folder from that if that is a help ?


No, this wouldn’t help, Time capsule is the reason why this issue occurred in the first place.

Let me try to keep this simple. If you don’t have anything from the old database which you wish to preserve, open up /Users/andrewjmoran/Library/ and delete the Roon folder from there.

Then go to our Downloads Page and download the Roon app again from there and reinstall it.

That should get you out of this state. I’m not sure which folder you deleted before or why there was a Roon folder under Music, but that should not have been the database.