Help needed with Pi-Digi+ (Beginner)

I have built up my digi+ kit and I am unsure about the software…
Can I put this - - directly on the SD card, or do I need to put something else on like NOOBS first or do I need to put both onto the card?
Thanks in advance!

You only need to install the image contained in the zip file to the SD Card. Just use one of these to do this:-

Use Windows? Use Win32DiskImager -
Got a Mac? Get ApplePi-Baker -

Once installed, plug it in the Pi and power it up. Then it will appear as a Roon Ready endpoint in Roon. (You will need to enable it in the ‘Audio Setup’ screen.

1 Like

Fab mate, thank you. :+1:

Hmm, its not working. I am on a mac, and I used Pi Baker, to format the card ready for noobs then just copied over the .img file. Is that correct?
The digi+ is not seeing the card as the usb card adapter i am using is not lighting up…
Any ideas?
I have to go out now but will be back in a couple of hours.
Speak later.

You need to flash the image to the card, not copy it…you are actually taking the img file and decompressing it to a folder structure on the flash card.

Noobs will not get you there…use either the dietpi image for pi board or the IQAudio image.

@Dan_Knight @Gordon_Garrity

Dan is the DietPi guy and Gordon the IQAudio guy… depending on which option you choose.

1 Like

Wow, I was told it was easy!
I have the IQAudio image for Roon but don’t understand how to ‘flash’ it to the card?

Google is your friend


1 Like

Im there! :smiley:

1 Like

Great, enjoy.

Roon with these type of devices is a mini-revolution.


1 Like

Still not loading the sd card. What a frustrating morning! Does anyone who knows how to flash the card on a Mac (MBP) live in Dorset? I need help before it goes in the bin!
Thanks in advance,
PS, I have tried PiBaker and the link above, that app does not work on my MBP running the latest OSX…

No, no… Not the bin! :wink:

Try Etcher to flash the .img file to your card.

Kindly note that you will have to enter your system password before the flashing begins. Just select the .img file (not the zip!), choose your card and press flash.

Anymore problems – don’t hesitate to ask. We’re here to help, and a Pi+Digi+ board makes a great Roon Bridge zone!

1 Like

Thanks but I downloaded Etcher and I selected the .img roon file, let it run, it then verified ok, it said its done and ok to remove, pulled it out of my MBP then it come up as operation failed with loads of digits displaying.
Its now called itself Boot and I can’t do anything with the card. I can’t erase it or anything. Needless to say, it does nothing in the Pi!
The bin is getting closer…

Could it be something to do with the Integral USB 3.0 card reader I am using?

I doubt it. The crash you’re experiencing sounds like a kernel panic on your MacBook.

The writing and the card (or at least the part of it that OSX can read) being called ‘boot’ sounds like the writing itself went OK. When you put the card into the Pi – what happens exactly? What do you mean by ‘it does nothing’? Do you have a display attached to the Pi?

The flashed card is supposed to boot the Pi, acquire an IP address over ethernet and present itself as a networked devices in Roon (Settings > Audio). Do you see anything there?

I see nothing under Roon sound tab. The card reader does not light up when inserted in the Pi, but it does in the Mac. I don’t have a display or keyboard attached, should I perhaps? I do have ethernet connected…

Wait a minute… Are you plugging the card reader into one of the Pi’s USB ports?

If that is the case – remove the SD card and put the card itself into the tiny little card reader at the bottom of one of the small sides of the Pi itself.

And no – you will not need a monitor or keyboard attached to the Pi – just Ethernet is fine.

I have attached a monitor and got nothing…

yes i am…I didn’t see a micro slot!

1 Like

Here it is:

1 Like

Found it…I will let you know…

1 Like