Help! Roon Arc issue

When I setup port forwarding it works for awhile then stops. I think the computer running my core is switching IP’s. Is this possible and is their a fix?

Depends on your router but there is a fix. We will need to know how the router is configured

  • How is port forwarding set up, UPnP or manual?
  • Do you use DHCP? (Probably and hopefully yes)
  • What’s your router model? (Decent routers can be configured to always assign the same IP to the core, or to update the port forwarding rule when the core’s IP changes. On poor routers it might be necessary to use a static IP for the core)
1 Like

I had the same trouble as you, I think. I had to disable this setting in my FiOS router. Roon was setting up port forwarding automatically via UPnP, but my router was turning it back off if it sat idle for several hours.

I use a NetGear AC1450. I have UPnP set up. Not sure how to tell about DHCP. I found these settings. Do I need to change something here/

The “Use router as DHCP server” is checked, so DHCP is enabled. This is in principle good, it assigns the IP addresses dynamically to devices in the LAN, so you don’t need to take care of it (which is always error prone).

However, with DHCP the addresses can change every time a device asks for one. If the router is smart, it should update the port forwarding rule to the new IP, but it may or might not be smart enough. Your router’s manual says that you can configure DHCP such that it does NOT change the IP for certain devices but always assigns the same one.

So let’s check on page 38 (the next page):

Choose an IP in the range to (so the fourth number between 2 and 254), which is not yet used by something else on the network. (This range is the one shown in your above screenshot, for the range your DHCP is configured to use). On the Router’s Attached Devices screen (where you also got the Roon Core’s MAC address from), you should see all devices and their current IPs - simply use the one that is currently assigned to your Roon Core. (The Roon app also should be showing this same IP address in Settings > Roon ARC)

Then go to the UPnP settings and ensure that the UPnP Port Forwarding table shows this same IP:

Then try if it works now continuously without the issue. I guess it will. If it stops again, compare the IP address in Roon ARC settings and the one in the UPnP Table to check if they suddenly differ. If so, something would be weird, but I don’t expect that

Thank you so much for writing this detailed walkthrough. For some reason nothing shows up in the postmap table. Any ideas?

So you did this and then clicked apply and nothing shows up?

Did you try going back to the Settings in Roon > Roon ARC? Maybe you have to click Refresh there so that Roon tries to set up the rule again. Here’s a screenshot of mine, which is working, but you should have a similar refresh button somewhere.

Maybe after that a rule shows up on the router (or it simply starts working). UPnP will only create a rule if the server (Roon Core in this case) asks for it

I have no idea what’s going on but IN the process of doing the above steps the IP will change before I have time to finish the steps for the handshake. So when I’m setting it up The Roon Arc screen has already changed the IP as well as the Roon Core Computers IP. Is there some other setting in my Router I need to configure? Like stopping the constant refresh of the IP? This is so frustrating.

The address reservation as described above should do just that. It should ensure that the Core always has the same IP.

You may want to reboot the PC with the core so that it is informed that it should use this IP

Then after that UPnP as far as I can tell should be able to set up the forwarding rule for this IP.

If you can’t make it work in the way your router manual describes it and as I am entirely unfamiliar with your router, paging @support

Thanks Sue

@support Any other ideas?

Hi @David_Burkholder,

A few things to consider:

  1. You’ll need the Windows Core and the router to agree on a static IP address for your Core. Since your Core IP address is changing before you can set a manual port forwarding rule OR even reserve a static IP in the router’s configuration, let’s first try to set a static IP on the Windows device and communicate that to the router by disabling DHCP. Follow these instructions

  2. Test with that IP address after autoconfiguring UPnP. See if ARC remains stable.

  3. While likely unrelated to your issue here, your router has Quality of Service (QoS) prioritization that can filter out Roon and ARC traffic. It might be worth disabling QoS or setting a rule that prioritizes TCP and the port specified in Roon → Settings - > Roon ARC. You can read more in the Netgear router manual here on page 39:

  4. This is a dual-band router. Verify that you’re not trying to connect to Roon and ARC on both frequency bands, as this would effectively be two subnets.

Thanks Connor,

I monitored it for awhile and it looks like it doesn’t change IP immediately. I set up the port forwarding and then it works for around a day or so then changes. Why does it work and then all of a sudden stop. I tried setting a static IP on Windows and couldn’t get it to work. I thought this would be plug and play but I can’t get anything to work.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.