Help! Roon doesn't allow me to sign in?

Missed that, must have been driving.

Could be that an update is all that’s required.

@xxx :+1:, I recommended the pc to be off in case there’s a conflict between it and the NAS, in the unlikely event they’re both called the same :man_shrugging:

The remote app update didn’t resolve the issue. I de-authorized the core, and following that, I was able to log in. It still recognized ‘IJsvlakte’ as the core, which is quite strange. Unfortunately, the database was empty. I have now added the folder with music files, and it is currently rebuilding the database.

Another issue that’s quite bothersome is that every time I start Roon, the database is empty, and I have to rebuild it after adding the music folder. Do you have any thoughts on how to prevent this from happening?

Good news then.

But

Allow time for the database to rebuild.

Once complete, reboot the NAS, force close the Roon Remote app.

I’d be surprised if that doesn’t resolve your issue.

I had similar occur today. I logout out of Qobuz and logged in Tida.

My whole library, Ripped CDs and Tidal were gone. Did the above and all there.

Hope we are helping you through this sufficiently with you :+1:

All the help is very much appreciated! Unfortunately, the situation further detoriated.

So, I gave the app a day to rebuild the database and wanted to login today. But it doesn’t work. I select the core (IJslvakte), chose ‘login’, I see the roon icon with ‘logging in’… and nohting happens.

I tried on my phone and with the PC. I updated the app on the phone and reinstalled the Roon on the PC. No difference.

This the screen I’m seeing on the PC:

And after a while this:

And this is an endless loop. (if I click ‘login’ it starts all over again with the same results coming back to this page).

This is so frustrating… :frowning:

Us fellow users understand your frustration.

Going to suggest something not advised yet.

Power down your NAS. Leave it off.

On your Roon Remote (ideally your phone or tablet) and with your PC on, try seeing if a Core is available. If not, then you don’t have Roon Server on the PC and clears that up.

I’m curious to see if you have Roon Server running on your PC, which has been sharing the same name as your NAS. Could be barking up the wrong tree here. Just a process of elimination as I can’t be there to help in person.

If no other Roon Server, I’d download Roon Server on your PC, set that up as your core device, just in an attempt to see if there’s an underlying issue on your network. If you can login, not a network issue, but likely to be your NAS with the issue.

Hope this makes sense.

https://roon.app/en/downloads

I’m getting closer…

I tried the above. With the NAS powered done and PC running, my phone doesn’t find a roon core. So I don’t have two cores for sure.

Somehow, I managed to login again. Both, in the phone and from the PC remote app. So that is good news. The bad news: something is wrong with the catalogue. All recently added music files don’t have a picture anymore (before this issue, there were pictures). And also the indication when they were added is incorrect. The last files say ‘3 days ago’. But I haven’t used roon for at least three months. So that is impossible.

How can I correct this?

Gain, the help I’m getting is much appreciated! :pray:

Addition: in the folders that don’t have a picture in Roon, a cover file is available (folder.jpg as in the other folders). And my libary setting for illustrations is ‘best’.

1 Like

All your reported issues so far are related to your Roon Server installation on your NAS. Please try to provide more details about that setup (for example: RAM size, library size [track count], is Roon server installed on an SSD or HDD [internal or external], …). Please make sure your NAS is healthy (consult NAS log files and diagnostics, run [storage] diagnostics if needed).

1 Like

Here some extra info

  • NAS specs: Synology DS918+ , 4GB RAM, Intel Celeron J3455 quad-core 1.5GHz, turbo 2.3GHz
  • Roon is installed in WD RED internal drives
  • Catalogue: 489 artists, 657 albums, 9457 tracks
  • NAS is healthy (all other tasks on the NAS perform excellent, 2,7 TB free space)

Some extra info:

  1. Didn’t use Roon for a couple of months and it performed good and fast the last time I used it.
  2. I noticed that more covers are missing (not only the latest additions).
  3. The albums that don’t have a cover have all ‘unkown artist’. For some of them, it are very famous artists (eg. Adele) and other albums from that same artist are recognized.
  4. I am 100% sure that when I last used Roon all these covers were displayed in Roon.
  5. For (almost) all albums a cover jpg file is available

Possible options:

  1. I have a catalogue backup from may this year. Don’t think I added lot of new files since then. Might it be a good idea to restore that version of the database?
  2. Could it help to rescan the libary? (if that is possible?)

Depending on what other processes and software are active on your NAS, 4GB RAM might not be enough (4GB RAM is considered to be the bare minimum amount for NAS installations but no guarantee for stable performance AFAIK). It is also recommended to install Roon Server on SSD and not HDD.
Do we talk about a library consisting of local files only or do you have streaming services connected too? Roon may need considerably more RAM when you use streaming services. Also during times when Roon imports albums and/or updates metadata, more RAM is consumed than when it just sits idle or serving music.

While missing covers may also be caused by network/firewall related issues, the overall reading through your case makes me believe it’s more likely related to your NAS somehow. Roon shouldn’t create a new database on its own unless the old one becomes completely corrupted/unavailable. Might be caused by insufficient RAM, storage issue, other process that blocks access, rights issue, … . Some of the issues could be caused by firmware updates of the NAS. Please check if the installed RoonServer package is the right one for you. There exist different packages for DSM 6 as well as DSM 7. You can also take a look at Roon’s log files to see if they contain pointers to the cause of your troubles. If you can’t interpret them, Roon support might be able to assist you with that (but it may still be days until your ticket reaches the top of their list).

Looking at your NAS specs I’d say this is a good starting point for the issues. The Intel Celeron J3455 is a 2016 model and low spec based on:

https://roononnas.org/de/synology-dsm7-2/

And

Three monhts ago everything worked like well and I would even call it fast and very responsive. I didn’t increase the size of my libarty since and if my NAS was sufficiently fast and up to date three months ago, it should still be okay now. I didn’t install a new Roon package and I didn’t upgrade from DSM 6 to 7. If my issue would be related to speed etc. I could imagine that a newer, faster NAS or SSD would be an option. Actually I have always planned to transfer Roon to a SSD, but because it was already so fast and responsive, I never felt the need. And also: the problems started with the double core error message. Hard to believe that this is caused by a NAS issue.

I think the current issue is, that Roon doesn’t reed the embedded cover files. So, if Roon can include a file from the web, it shows a cover file, but if it fails, the embedded files are not shown while the setting in Roon is correct (select the best image). At least, this is my analysis so far. And how can it be that files I added months ago are shown as ‘added three days ago’. That is not caused by a slow NAS? Oh, another issue I had for a while: every time I opened Roon, the database was empty and I had to manually add the right folder and it started to import the catalogue again. That is not caused by a slow or old NAS.

I’m still considering what would be the best next step (I’m not going to order a new NAS unless there is eg. evidence that a new roon update is not compatible with my current NAS).

Can I force to do a full rescan? Or is it wise to restore my old backup database?

There never was a double core issue. The issue as reconstructed from your description was the Roon DB on your NAS has gone poof for still unknown reason and a new empty one got created.

This is not why you started this thread only 4 days ago.

How should Roon know if you always had to start fresh with an empty DB? Something is/was very wrong with your setup.

It is under minimum specification for a Roon Server. Depending on your use case, the processor might do, the HDD may make your experience sluggish (speculation: and there may also arise situations where Roon runs into timeouts waiting on data [swapping] and failing) and there might be simply just not enough RAM for your setup.

Troubleshoot your issue. Try to find clues what causes all the problems for you. Check log files (NAS and Roon) start monitoring the situation (RAM, CPU load, when do things happen, is there a pattern [example: always when a NAS backup runs, always when NAS disk check runs], …).

Note: Others don’t have your issue (or an issue at all). Roon falling for you is most likely just a symptom of circumstances occurring on your NAS outside of Roon’s control. Others can just take what you revealed so far, point out the likely shortcomings of your setup and give you hints for troubleshooting. Without someone providing a clear root cause, no one can provide a definitive corrective measure.

Why should you want to do that? That is what happens anyway if you start with a new empty DB from scratch as you wrote above.

Without knowing the root cause of your problems I don’t know too but likely not. If the issue is rooted in the library (size, specific content) then you just reintroduce the issue by restoring the backup but recreating the library from scratch from the same source files and streaming libraries may do just the same. So going through the additional effort without first figuring out what’s going on seems pointless to me.

As above is pointed out, my current issue is not in line with the topic anymore so I created a new topic for this.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.