Help Setting up Roon arc with Nokia Router

Roon Core: Macbook Pro Intel machine
Router: Nokia HA-140W-B
Problem: Roon core can’t connect to Roon arc.
Message on Roon core:
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nAction Failed\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}
Tried Port forwarding on router using WAN PORT 12001 LAN PORT 8008
Can confirm have enabled UPnP on router
hope you can help…many thanks.

Hi Mitesh,

Roon support like to have 1 request per thread, so I have moved your post to a new thread so Support will see it when they get back in on Monday.

1 Like

@Mitesh_Doshi, I believe you need to use either UPnP or port forwarding, but not both. If enabling UPnP is not working, then port forwarding should be configured next.

Based on your note, I don’t believe any of the ports you are showing are what Roon ARC uses. Can you please look at your Core’s Settings → Roon ARC tab and see what port number is shown? Typically, the Roon team has seletect port 55000 or port 55002, and either works, but the port forwarding rule your create on the Nokia router must use the port number that the ARC tab identifies.

Hi Robert_F,
Tried using 55000 port and 55002 port niether of them work…for port forwarding
unticked the UPNP box as well.
This is the message I get from the ROON ARC settings page

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

The port forwarding diagnostics you’ve provided suggest that UPnP is not properly configured on your router or not working correctly.

Please try the following steps in order:

  • Reboot your Roon Core and networking gear (router, modem, switches, etc.)
  • Try to enable UPnP/NATPMP in the web administration interface for the router
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Try to update your router firmware
  • Check if your modem is in Bridgemode and if not, try to place into Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service providerand what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?



Hey @Mitesh_Doshi,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Following up on this thread, I wanted to see if you’re still running into issues get Arc setup? If so, here is a breakdown on how to set up port forwarding for your specific router:

I’ll be on standby for your reply :+1:

Thanks for getting back to me.
Still no joy.
I have set every thing the same in Image 1 in the port forwarding section of the ethernet gateway for the router, except the internal client which I can’t change. It is not the which is in image 1 of your illustration.
I have tried both images 1 and 3 from your illustration.

this is what I get

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Hi @Mitesh_Doshi,

Could you post a screenshot of your forwarding rule and a screenshot of the roon Arc message (Roon App via **Settings —> Roon Arc). Especially the ip address and port number shown there.

Kind regards,


Is there a reason why you can’t use the default port 55000? I’d try the default port 55000.

Also try setting the protocol to BOTH.

If port forwarding has been manually set turn of UPnP if you haven’t already.

Hi, I’ve tried using 55000 for the WAN port and 55000 for the LAN port, still no joy…also both tcp/udp in protocol
UPnP is turned off.

is this correct?

Does it work?

That’s the configuration I would expect to see.

Don’t forget to set 55000 within Room settings.

55000 Set in Roon core (software)
Still doesn’t work…


Is the Nokia Router you mention you ISP device or is there another router/modem in the chain.

No the Nokia router is the only router…nothing else in the chain.
I don’t have much mobile coverage on the iphone or ipad…does that matter when trying to connect the core to the Arc?

If you phone or tablet are on WiFi and on the same network as your core, then I’m stumped at what could be the issue.

I’m not familiar with the Nokia router, but what you’ve set does suggest it should be working.

You may need further help from the Roon support. Please be patient with them. They are getting through lots of other posts and it takes time.

Hi Lewis,
When my iphone and ipad are on the same wifi network Roon Arc can see the macbook pro Core in settings and it works. However on the macbook pro core when i try to connect to Arc via roon settings…under Roon Arc when i test the connection to Roon Arc it states it is not ready and Roon arc will not be able to contact the Core. And i get the error message in the box for diagnostics data for Roon support.

Hey @Mitesh_Doshi,

Following up on this thread, I wanted to ask you about your specific Modem setup. Do you have a modem in your network? Or, can you confirm that the Nokia is a modem/router combo? The modem is what we’ll need to set into bridge mode for it all to get properly connected.

And backing up a bit, can you confirm that you have a static IP issued from your ISP?

Lastly, I would suggest updating both your Roon core and arc devices to the latest Roon build, and let me know if your issue persists :+1: