HELP. Suddenly Roon won't play more than 2 minutes without stopping (more) [Solution: Restart]

Core Machine

ROCK on Intel NUC 4 core i5 32GB. All devices re up to date.

Network Details
Ethernet connected. Nokia Beacon routers


Audio Devices

  1. USB to ROCK
    2 ethernet/USB bridge to DAC
  2. and 4. Macbook pro, on ethernet, as bridge to USB to 2 DACs


Library Size
Not very big.
Mostly Tidal.


Description of Issue

  1. Was working mostly fine for ages
    2 Suddenly Roon keeps stopping, then “nothing p[laying”, apparent disconnection, zone re-appears, paused, may be restarted. began last night suddenly.
  2. Actions taken:
  3. eliminated grouped zones (no effect)
  4. restarted ROCK, 3 times for journaling disk repair (no effect)
  5. Restarted server and ROCK (no effect)
  6. Restarted router (no effect)
  7. tried different DAC (no effect)
  8. tried both Tidal and local files (no effect)
  9. Restarted Roon on the remote PC acting as “network-USB bridge”

It is now basically unusable and I am out of things to try.

Any advice welcome.

Support please help. Was there an automatic update that might have caused this?


OK, i appear to have a solution, but this raises questions about Roon, its stability and its fault reporting.

Note above that had restarted the remote Roon (on Macbook pro) as well as the ROCK. No effect.

In desperation i shut down and restarted the MacBook pro. It had been working fine for all other applications, with solid internet connectivity. In fact i played music from another source white Roon was misbehaving.

The restart fixed it. Since restarting Roon had no effect, and since all other apps worked, i can only conclude that Roon somehow corrupted a setting and failed to clear it when restarted, or to repot an abnormality. Bad form on all.


1 Like

I’m not a Roon defender by any means, but it’s possible that whatever the corruption was, it wasn’t even caused by Roon. Agreed that having to reboot the machine means that there was something outside of the Roon executable that caused the problem…but it doesn’t necessarily mean that Roon corrupted something. Not saying it didn’t either…just pointing out there isn’t an unavoidable single possible cause.

I do agree that Roon’s error reporting is pretty bad and rarely provides a troubleshooting clue.

You are correct, but its very suspicious. And the fact that all other processes were unaffected creates a little smoking gun, but purely stochastic - could be wrong. Then again, i have had ROCK corruption with no error reporting; core (on mac) corruption with no errors reported. So,… :slight_smile:

I’ve been wanting to build this MacBook Pro out of the equation anyway and this may be another impetus for me to build RPI 4 based bridge with a custom linear power supply, transformer isolation, etc.

I also had really weird issues with an old (El Cap) mac book in this position previously. Coincidental with an upgrade, i lost up sampling and exclusive capabilities that worked previously. Roon support asked a bunch of questions and disappeared never to be heard from again… clearly an issue between them and El Cap. So my faith in Roon is limited. I have a love hate relationship with it, Love the idea, beginning to hate the implementation.