Help using USB DAC / output from NUC

Core Machine (Operating system/System info/Roon build number)

NUC 10i7 FNH
Version 1.0 (build 186) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

All wired & using Linksys Velop as a mesh networking system

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Oppo 105D
MacBook Pro

Description Of Issue

Trying to connect my NUC which has just been installed with Rock directly to my Oppo 105D through the USB DAC input. I’ve had a few issues recently where the Oppo USB DAC hasn’t been recognised as an input by Roon and it appears my MacBook isn’t seeing it today. If it’s turned on / off and the cables are pulled out etc and reconnected, sometimes it does reconnect.

I’m not sure if there’s anything I can do about that?

I would like to be able to connect the NUC / Rock directly to the Oppo and use this for now. I’m happy to use a headphone jack or optical or coax etc but not sure how I can access the NUC settings page and tell it to output to other services?

Any help to get this working temporarily would be fantastic - thanks!

Hi @Nick_Shiroi1,

Have you tried a different USB cable for the Oppo yet? Sometimes USB cables become faulty so I would give this a try.

What happens if you connect the Oppo to the Macbook via USB? You can still keep the Core on the NUC and have the stream run though the Macbook as a test (enable the zone in Roon Settings -> Audio).

I haven’t tried a new cable - will try that today

I’ve tried the MacBook straight into the Oppo & it works sometimes but not consistently. Are there any settings I can change on the Oppo that may make it work better? Like the sleep function?

Is there any reason why the NUC shouldn’t be used as an endpoint?



The NUC is your Roon Core? Roon doesn’t support “Inputs”. The endpoint for playback is your USB connected Oppo and not the NUC. Playing a disc on the Oppo will not feed any sound back to Roon.

I’m not trying to input anything from the Oppo to the NUC

I’m trying to output from the NUC to the Oppo…

Hello Nick, I have a NUC8I7BEH with USB connected to a OPPO 205 USB input. Roon does not show the zone unless the OPPO is powered up. I have to use the OPPO input selection to specify USB input for the music to play. it is not selected automatically.

I also have a 105 but it is boxed up, have not tried it with Roon and don’t know if it works the same.

Hi Mike, thanks for the reply. Sorry I should probably have stated that. I’m aware that if it’s off, it’s not visible. The problem I’m finding is that most of the time it’s not visible but sometimes after restarting etc - it shows up. Sometimes it doesn’t…

So would like to use another output. I connected the HDMI but can’t access the NUC’s settings to output the sound through HDMI?

I do have the NUC HDMI connection to my receiver. That zone does shows up with the receiver off and that is different from the OPPO USB connection.

In the Settings - Audio - Connected to Core - I have options for HDMI 0 through HDMI 4. I use HDMI 0 for the zone.

What do you see listed on your Audio page?

Another thought that you may already be aware of, is the OPPO USB firmware up to date? That is separate from the standard OPPO firmware. At least it is on the 205.

I can’t see the core in the audio section - I can sometimes when the USB DAC works but not otherwise?

I’ll check about that, I don’t know if it’s a different firmware! Good idea - thanks!!

Hi @Nick_Shiroi1,

That’s very strange, you should always be able to see the Core’s audio outputs under Roon Settings -> Audio. Could you share a screenshot of your Roon Settings -> Audio when the Core is missing? This is when the Macbook is connected to the ROCK Core and not when the Macbook is running in Core mode, correct?

Yes, when the NUC is running Rock. I’ve taken the Core off everything else

Here’s an image

Hi @Nick_Shiroi1,

Thanks for the screenshot. I believe I might have an idea of what’s going on here and why you’re not seeing the HDMI zone.

This NUC model is currently not on our list of supported NUC models to run with ROCK.

I suspect this is causing the HDMI output not to be properly displayed and the Core section doesn’t appear if there is nothing connected to the USB output.

I’m a bit surprised you managed to get the NUC10 working with Roon through a wired connection - there were previously some other reports that the on-board Ethernet adapter wasn’t working with ROCK, did you use a USB -> Ethernet adapter for the network connection?

In either case, this is still a big factor in the issue:

I would try to get the Oppo stable on your Macbook first and only after that try to use it when connected to your ROCK (which is not certified yet).

Did swapping out the USB cable lead to any positive results?

Thanks Norris

So I have a USB > Ethernet adapter, it wouldn’t work otherwise!!

So I changed the cable & was all excited because it started working. I stopped it and turned it off, it was still connected and tried again about an hour later and all was good. A few hours later it’s gone and I can’t get it to connect again?!

Here’s an image when it was briefly connected

No clue what the problem is, but it seems to need to be disconnected and reconnected / stopped & started and then it’ll work!!

Figuring I should buy a small HiFiBerry with a Coax output or something as a temporary measure so that it can continue to work.

I can’t get the HDMI output to the Oppo to work but figure that may either be because the NUC bios isn’t enabled for HDMI output? Or because I can’t get into the Core settings to enable the HDMI to make it work…?!

Any suggestions on how I could do that?

Hello again, I’ve had the NUC HDMI connected to my OPPO and now to my receiver. This is a view of the HDMI connected to Core options from my settings - audio page. The item showing LR NUC is HDMI0. You can’t get HDMI out to work until you have these options to choose from to get the zone setup.

As Noris mentioned your NUC is not currently one proven to work with Rock. This seems to be the primary issue you are facing.

Isn’t the issue with the Oppo though?

I’m figuring that I haven’t set the NUC up to have the hdmi sound & probably need to mess with the bios?

I can’t understand how you get in to change & enable settings in it…no one has been able to explain how to do that?! :frowning:

I think pressing F2 during NUC power up will take you to the BIOS screen. Have no idea if its a bios issue causing the problem with Roon - Connected to Core - in Setting - Audio.

You should get USB out and HDMI out in that section of the Roon audio settings display. In my example below it shows both the HDMI and USB zones enabled. The USB entry will only be displayed with the device connected and powered up as we previously covered but the HDMI 0 - 4 should always be there if things are setup and working correctly.

So there’s two issues… 1) the oppo USB DAC input seems hit or miss! and 2) The HDMI’s aren’t set up correctly and could be down to BIOS settings or the fact it’s too new and isn’t properly supported.

Solutions, find an optical / coax output for the DAC?Not sure if that’s possible or if I was to buy a hifiberry type device and not use the NUC as the endpoint as well as the Core?

Oppo solution - maybe change the power settings so it isn’t energy efficient and maybe that’ll keep the connection live somehow?

I would think its one issue, Roon os/software is not detecting something in your NUC configuration consistently. That is probably why it’s not listed as certified yet. The NUC8I7BEH was listed, then not listed for a period of time, then listed again when it came out. Luckily for me the timing was right and Roon had the kinks worked out before I built mine.