Help With Cuda Offload

Looking for advice on what drivers and instructions needed for Windows 10 that will allow Cuda offload in Hqplayer ?

Anybody ???

Requirements are specified on the web page under “System requirements, CUDA offload”:

Then you just tick the “CUDA offload” checkbox in HQPlayer Settings-dialog.

When installing cuda toolkit 7.5 for cuda offload do I install the local or network installer.Looking ror someone who has installed on Windows 10 advice ?

Have you installed the Nvidia driver for your graphics card? Then I think that is all you will need. You can use Cuda-Z to check if your driver is properly installed and if your graphics card can be used for CUDA GPU processing.

If you still want to install the Toolkit, local vs network installation should produce the same results, they install the same stuff. The local installation will download a huge file (1 GB) that you double click to install vs a network installer will fetch the installation files as it installs.

Tried to download cuda-z.Can not download .Turned off firewall.Never had a problem with downloads before ?

Which browser are you using and what was the error message, can you provide a bit more information? I just downloaded it again without any issues using Chrome browser.

Finally got it to download.Had to turn of my antivirus and go into permissions

So with cuda -z what am I actually looking for ?

Do you have a CUDA enabled nVidia GPU ?
Jussi specifies a Compute Capability of 3.0 for HQP.

Have you installed the latest driver ?

If yes to both of the above (which is the only thing you need cuda-z for, checking those two things) then tick CUDA offload in HQP and you’re done.

@andybob is right. If you have a CUDA enabled graphics card and have installed the drivers, you are ready to go.

Cuda-Z just gives a visual confirmation if you need one.

Have cuda enabled card and latest driver.When I enable cuda offload all I get is stuttering.Uncheck plays fine

On Windows, poly-sinc family of filters can sometimes cause stuttering when used with CUDA. try choosing poly-sinc-2s or closed-form. If you have pipe-line SDM enabled, try unchecking it and restart HQPlayer.

Note that depending on the rest of your system, you may or may not prefer poly-sinc-2s or closed-form. If that is the case and if your system can already handle poly-sinc, then unchecking CUDA offload is likely the best option.

There are other threads in this forum and in ComputerAudiophile forum where you can find more information on the filters and stuttering issue too.

Okay works wth cuda offload with closed form and all the -2s filters.I was go to buy a better video card with more cuda cores but if it won’t work with the regular poly sinc filter would I just be wasting my money ?

And I really do appreciate the help guys.

If you enable CUDA offload, you have to enable Pipeline SDM too, as recommended by Miska.

I do have them both check off?

With cuda offload enabled can not use and regular poly since filters doesn’t matter if upsampling to DSD64 128 or 256

I have a GTX 970, i7 3.5 GHz processor and I have had similar experience with DSD256 or more. Be sure to upgrade to the latest version of HQplayer.

But the problem is only with DSD not PCM and fortunately my Chord DACs like being fed PCM so I can have the CUDA offload enabled for all filter families.

I see there is a new beta version will have to try that tomorrow