Help with laggy Roon interface and SLOW Tidal - HELP!

I changed some settings in NVIDIA Control panel and now get 20-30 FPS but still laggy Tidal playing. I’m constantly getting the “Tidal media is loading slowly” message. However, the Tidal app itself runs absolutely fine. It’s only playing Tidal through Roon that is not working.

an Orbi satellite is running over wifi … so this is probably where your issues are…if you can move your setup to the real router direct to the ISP then see how that goes. maybe a loooong lan cable would be OK to test if you have access to one. could also be DNS settings. Try adding 1.1.1.1 to your DNS server list.

what do you get on a speedtest.net or fast.com speed result?

I don’t think my network latency is a problem, every app runs smoking fast, my local Roon files stream with no delay, only Tidal over Roon is a complete laggy mess.

Also, I have an iPhone running Roon downstairs, and it streams Tidal just fine over WiFi. Tidal used to work just fine on this machine but for some now it’s hosed.

Tidal app is not the issue here its more likely how roon locates and communicates to tidal servers that is the what I am trying to guide you with here. the wifi orbs connection is looking OK so thats one thing ruled out…now DNS?

I just saw your core is running on a NAS… how is that connected…if its on another orbi then you double hopping roon traffic (and tidal) over multiple wifi connections…not ideal

also roon on a NAS is subject to the performance of the NAS…what model of NAS is this. Most NAS cpu’s are not well equipped to run a Roon Core. As roon make updates to the core features this only puts higher demands on lesser spec’d systems like NAS’ so what worked yesterday might not in a subsequent update.

you haven’t stated what Roon versions you are running for the record yet either.

https://kb.roonlabs.com/Roon_Server_on_NAS

Hi @Jason_O_Brien,

If you go to Settings > Services and choose TIDAL and then lower the streaming quality to Normal is there any change in your ability to stream?

I’m on Roon 1.7 Build 528. Nas is QNAP TVS-671. Roon is on an SSD. QNAP is double-ethernet to the base Orbi.

Changing the Tidal streaming to Normal did not help. It takes around 10 seconds for anything to load once I select “Tidal” in the sidebar, it takes 10 seconds or longer to click an album and have it show up, and it takes 10-infinity seconds to play a track from Tidal (sometimes it just won’t go at all).

I haven’t messed with DNS yet… is this DNS on the router, the NAS, or my computer? If it’s the router, I can’t mess with that until tonight since my wife and I are working from home.

totally going to depend on your network setup as far as DHCP or fixed addresses

Hi @Jason_O_Brien,

As @wizardofoz mentioned this will depend on a number of factors. A good place to start is likely with your Orbi router. Orbi has some information about changing DNS settings here:

https://www.orbisupport.com/how-to-modify-dns-settings-of-your-netgear-orbi-router/

Tonight I tried the following:

  • Updating Orbi DNS to 1.1.1.1/1.0.0.1
  • Deleting Roon Server on QNAP
  • Reinstalling Roon Server on QNAP
  • Rebooting modem, Orbi, and NAS

I am still having Tidal issues through Roon. On my MacBook, for instance, Tidal tracks won’t even play at all. They just sit buffering forever.

Anything else I can try? I’m at the point of not renewing my Roon license and looking for other solutions.

1.0.0.1 ??? I would use 8.8.8.8 in place of that along with 1.1.1.1

Please remove one of the two Ethernet wires and try again as it is very unlikely that the Orbi satellite supports any Ethernet link aggregation (802.3ad). You may also want to change the LAN settings on your NAS to accommodate for that change should you have previously configured it for link aggregation. If not: What’s the purpose for running two LAN cables to the satellite then?

2 Likes

This might be it! The Orbi 6 does support aggregation but I forgot to set it up when I switched from an older router. As a quick test, I removed one of the ethernet cables and rebooted everything and it appears to be working great. Will report back later today if that holds true.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Core Machine (Operating system/System info/Roon build number)

Windows 10 updated, 9900k, 2080ti, Gsync monitor, latest nvidia drivers.

Roon server on QNAP TVS-671, database on SSD.

Roon on latest updates on both computer and server (build 528).

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Orbi 6 mesh, usually pull about 400mb down on this computer and 150/200 up.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Schitt Gungnir to Mjolnir 2.

Description Of Issue

Can’t play Tidal tracks. They will sometimes try to load for about 20 seconds and attempt to play part of the track, but then it stops. Had a previous ticket here: Help with laggy Roon interface and SLOW Tidal - HELP!

but the problem is back and worse than before. I’ve tried restarting all devices, including the entire network several times.

Roon tracks play perfectly with no delay or buffering. Tidal on this computer runs perfectly on Hifi/Master quality.

Hi @Jason_O_Brien,

It looks like things were working for a bit before it started again after you stopped using Ethernet aggregation. How long did it take for things to come back?

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs as well as which track you’re trying to play. Then respond here with that time and track and I’ll make sure we review the diagnostics related to that timestamp.

At 10:51am CST today I opened Tidal from the sidebar, clicked the new Thievery Corporation album Symphonik, and clicked Play All. It took a long time for each of those pages to load, but surprisingly it DID start playing the track after about 10 seconds. However, it only made it through about 10 seconds of the track before it stopped playing all together. No error message.

Sorry, missed your first question. After removing the extra ethernet cable, it worked fine for the few minutes after while I was testing it. The following day when I went to try again - it was back to not working.

Thanks for the help!

Hi @Jason_O_Brien,

I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link.