Help with setting up Roon on Raspberry Pi with Allo DigiOne [Solved; select in settings]

I’m currently running a Raspberry Pi with HiFiBerry Digi+ Pro, which is working really well. However I hear that the Allo Digione provides better sound quality so am looking to switch over.

I’m looking for an idiot-proof guide to installing Roon onto the DigiOne. I have no Raspberry Pi / Linux skills, so I hope it is easy.

The HiFiBerry was a breeze to setup, plug-n-play. Hoping the DigiOne is the same.

It’s even easier as you can have a GUI. See here:

1 Like

This looks great, thanks! I will bookmark this so I can try it out once the DigiOne arrives.

This is also worth a try if you only want Roon.

I’m very pleased with the sound quality and easy installation.


Allo DigiOne is on order! Should have it tomorrow

The DigiOne has arrived and is now setup. I can see the device in Roon, it appears as “DietPi” with two audio outputs available:

  1. bcm2835 ALSA
  2. bcm2835 ALSA IEC958/HDMI

Unfortunately both outputs seem to be limited to 44.1 or 48kHz. Am I missing something?

Never mind, I figured it out. You have to select the DigiOne as the soundcard in DietPi

Dear all,

I tried to submit my issue directly to Allo but no reply.

I bought the Allo Digione HAT and I’m really very happy about the quality of sound.
I use the board in the following setting:
Roon Server (intalled on my PC)
RPI 3 + Allo Digione (Meanwell Switching Power Supply 5V 5A, I know is not the best but it is ok for the moment)
Dietpi (last version) configured with Roon bridge and Allo Digione settings (following your documentation)
Marantz PM6006 (with SPDIF Internal DAC)
It works very good in terms of sound quality but I found the following issue:

I switch on my Marantz, after I switch on the RPI (and Digione too) I start to play music from the Roon Server and all is working very well, I can listen music for hours without any problems.

As soon as I switch-off my Marantz (or put it in standby mode), without to restart (or shutdown and switch-on) the RPI, when I switch-on it again the Marantz and I try to send music from Roon Server, music seems to be properly streamed to the RPI but no signal arrive to the Marantz (the led on the Marantz coaxial input blink, no signal in input). No software error on the raspberry no error on Roon server.
The only workaround I found is to reboot the raspberry.

The problem is no in the Marantz, I tried with other coaxial sources and I was not able to replicate the issue.

I configured something in a wrong way? Could be my Allo board faulty?

Hi All, not the same as the OP but I just got my Allo DigiOne with everything pre-installed. I can see it on my network and use the web interface but can’t see it in Roon as a device. Any tips?

Setup-wise: The soundcard in the RPI is set to Allo-Digione as required. I’ve connected the digione to my marantz ARV via s/pdif.

Ah idiot. Yep finally realised i had to enable it in settings. All good.

Thanks @Dan_Knight great product.

Hi, I’m currently involved in a Roon trial period. Great product. Currently I have it installed on my PC, using my soundcard and a CCA (to my receiver) as endpoints. I’m interested in the RPI and Digione scenario but don’t really understand the configuration.

Could someone explain where Roon will reside and how the RPI / Digione combo connect?