Help with streaming to chromecast devices

Core Machine (Operating system/System info/Roon build number)

Windows 10 on laptop. I5-2410 cpu@2.30 ghz. Ram 6gb. Roon version 1.7 build 667 stable 64 bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Asus router Rt-Ax92u. 2 of them. Ai Mesh system.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Jbl link music. Jbl link 300. Both have chromecast. Wi fi only.

Description Of Issue

I have one Lumin d2 hardwired in my main zone. I have node 2i in second zone hardwired. I just installed the roon system a few days ago.
Before roon I was able to stream to the two Jbl units via wifi, through chromecast with no issues. I do the speed test upstairs where the jbl units are and get 110 mbps.
Only have issues such as the audio doesn’t start when trying to use through roon.

The router has three bands. The jbl units are on the 5.2 band. Along with this tablet, its the only thing on that band.

Ok let me know what else you need.


Hi @4367,

Are all other endpoints working okay?

Does all content fail to play to Chromecast, both streaming and local?


Yes the two end points work perfect. (Lumin and bluesound hardwired)

And for both the Jbl link music and Jbl link 300, both tidal and my local music which is on a Wd my book don’t play through roon. And in contrast in the native tidal ap, ican send audio to them no problem as well as through the native deezer app.

(I forget to mention in first post that my local music is stored on a western digital mybook live, which is hardwired to router)

Try disabling multicast or IGMP on your router.


Ok, I can try that. I have the app on my tablet for my router so I will check for those settings.


Hi @4367,

When you say you are having the issue streaming to the Chromecasts, does it work at all?
Or does Roon show an error each time you try to play something?
Can you share the error message you are getting?


When I select a track in either of those zones, the time stays at 0.00.
No error message

And I’m able to control the volume,i can hear the volume steps go up and down…but no music

So I found a setting called igmp snooping and that is on the disable tab already.

And I found multicast rate and the options available are auto and then ofdm 6, 9, 12,18,24,36,48,54. I left it on auto.

Are those the settings you were asking about?

What you might try is toggling IGMP to on and see if that helps. It depends on its implementation if it’s best on or off seemingly.

O wow, my 4 year old was messing around with my tablet and I started asking hearing music from one of my chromecast jbl speakers! He was just taping the play pause button and it would start.

So I select a song and hit play and nothing happens. No music. But I can control the volume steps. If I hit the pause then play button, then the music starts. This seems to work every time. When I skip tracks, I have to repeat the process.

Oh and this works for my local music and tidal account.

Its definitely weird as I can stream from the native deezer and tidal app to the chromecast devices and it works fine.

I just checked to see what would happen if I let the song finish. If another song would need to have the play pause button and yes it does.


Kids are the future you know :smiley:

1 Like

I have a JBL Link 20 and it works fine with Roon, odd how these are acting oddly.

1 Like

Are you using an Asus router by any chance?

Nope, all Unifi network here.

1 Like

Ok thanks.

Hi @4367,

Have you verified if the 2.4Ghz band has the same behavior?
Can you please check this and let us know?

I will try that now.

Hi, ok just checked and its the same. Play pause to get it going and again for the next song. And local music is the same as tidal. And I put the tablet to 2.4 and thru the native deezer and tidal app am able to stream no problems.

1 Like

Hi it looks my problem is solved.
The answer came from another member.

I just did what this poster said and no issues. And for full context, the chromecast are both on 5.2 and this worked for local music and for tidal.

The only difference was I didn’t see the power of 2 under max pcm rate.
So I just selected max pcm rate.

1 Like

Hi 4367!

I did only see this option (power of 2) on some of my CCA. Reset settings to default and it will appear. Max pcm rate worked great aswell. With linear phase filter as i picked it sounded a little less harsch. Just a matter of taste and minimum phase gives a softer sound also.