Hi-Res files from Qobuz not playing

Core Machine (Operating system/System info/Roon build number)

My system:

Roon core on a Mac mini (M1) 500GB, Roon version 1.8, build 764. Media folder on the Mac mini, my library has over 2500 albums, 39 000 tracks. I am using the Mac mini exclusively for Roon, no other apps are running. WLAN is off on the Mac mini.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router: Fritz!Box 7590 (I live in Germany).

Ethernet: From router directly into an EtherREGEN switch, B-side of that to a NAD M10 streamer/amp.

I did not change anything in my network in the days before the problem occurred.

On the EtherRegen A-Side: Router, Mac mini, Apple TV, Ikea hub for motorized blinds.

There are other devices (NAS, iMac, Sonos, Airport etc.) connected to the router directly and via another (normal) switch.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

NAD M10 via Ethernet
Steinberg UR22 MkII interface via USB
Pro-Ject Pre Box S2 Digital via USB (as Headphone Amp)

Description Of Issue

Problem since March 15, 2021:

Hi-Res files stop playing after a few minutes (usually 2), Roon skips to the next track, and then playback stops ever earlier. A message: „Qobuz media is loading slowly. This may indicate a networking or connectivity problem.“ is displayed at the bottom.

CD-Quality files play mostly without problems.

What I tried so far:

  1. Changed the switch to a normal one (D-Link DGS-1005D) - no improvement.
  2. Checked the cables.
  3. If I play directly from the Qobuz app using another DAC (Steinberg UR22 MkII interface via USB), everything is fine even with 192 kHz files (I cannot play from the Qobuz app directly to the M10). But using Roon, also with the other DAC (Steinberg), playback of HiRes files from Qobuz stops. So I assume Qobuz is not the culprit.
  4. Roon via AirPlay to the M10 also stops playback quickly.
  5. Playing Hi-Res files in Roon to my iPad Pro 10.9 also stops (after 2 minutes), so the M10 can not be the culprit either.
  6. Two Sonos speakers are also in the system via cable. If I play to them through Roon, playback also stops after about 5 minutes. Message then is: „Roon lost control of the device“.
  7. Playing Qobuz Hi-Res files through the Sonos app works without a hitch. Sonos can of course only play up to 48 kHz, but the app somehow must manage to load the original 192 kHz file to downsample it.
  8. I also tried playing through NAD‘s BluOS. When I choose music from Qobuz there, it also stops playback of Hi-Res files intermittently after about a minute.
  9. Hi-Res files locally stored play fine through Roon.
  10. I used upsampling in Roon up to now without a problem. I have turned it off now to minimise network traffic - but no change.
  11. I tried restoring an older backup from the time when everything worked fine - that had worked before, when I couldn‘t even log into Qobuz - but that did not change anything this time. So I restored back to the latest backup. I also restarted the Mac mini several times.
  12. Disconnecting the USB DAC did not change anything.

So I am helpless. The problem is supposed to have something to do with my network, but I can stream 4K movies with no problem, my internet allows 100 MBits/sec. But it definitely has something to do with Roon too.

I am desperate, because I love Roon. I have been using Roon for more than two years now and have invested a lot of work to organise my media. It has been my greatest joy in these troubled times to listen to good music an a good system.
I also want to mention that I like Version 1.8. Both the look and functionality are awesome. I have not experienced any problems with it - until now.

Any ideas how I can listen to Hi-Res music again?

Hello @Hermann_Battenberg,

Thank you for the exhaustive testing and details, it’s very helpful for us.

What I’d like to see is a test using the simplest audio pathway available.

Can you try

A) Go to Settings > Audio
B) Enable the “System Output” zone
C) In the Mac sound settings set the “Output” to the built-in speaker
D) Try playing Roon to the System Output zone for a period of time.

If playback to the “System Output” zone is stable, we can start adding devices and seeing where things start to get unstable.

If playback to “System Output” is unstable, we’ll likely take a look at the network and Roon’s buffering.

-John

Hi John,
Thanks so much for responding so quickly, and on a weekend too!!
I did the test as described, but no success. I played a 192 MHz file from Qobuz (a Mahler Symphony - quite a torture for my ears through the Mac mini speaker :slight_smile:), and it timed out at 1:41 min and went to the next movement.
Let me know what I could try next.

Kind regards
Hermann

Hi @Profile - john - Roon Labs Community

I am quite disappointed not to have heard anything from you after my answer a week ago. (Is it because I did not copy your profile into the first line of my e-mail?)

But the good news is that my system seems to work fine again. After playing to System Output without any success, I tried all kinds of things, and I searched the Roon Labs Community for similar cases. I found one from Oct 2020 (Profile - Jacob_Harold - Roon Labs Community), who had a similar problem. Your colleague (Profile - nuwriy - Roon Labs Community) suggested changing the DNS server in Jan 2021. I did this on my Mac mini according to the instructions by Cloudflare - and since then I could play Hi-Res files without any problem. I don’t understand why, because I have been using Cloudflare all the time, just the lines 2 to 4 were different. It might be, that the DNS settings came from my router and now having them set correctly on the computer itself did the trick?

So I am happy now, but not quite happy with your support. (As it happens, also Profile - Jacob_Harold - Roon Labs Community had to wait a long long time before he received an answer again just 3 days ago.)

All the best
Hermann

Hello @Hermann_Battenberg ,

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Thank you for letting us know that the DNS change helped resolve the issue!
If you have any further difficulties, please do let us know and we can take another look, thanks!