Hi-Res FLAC not playing, they just skip tracks [Resolved, Audio Midi Setup]

My setup is a mac mini (mid 2011), running the Roon server and with a Denon AVR-4311 connected via HDMI.

The issue I’m having is that at least some FLAC files are not playing. The albums and tracks are visible in the GUI but when I hit play, it just skips real fast over the the whole track or album.

The FLACs that don’t work so far are 96kHz and higher at 24bit.

All tracks play fine via VLC and via a Roon client on a different computer.

I tried to limit the export quality via the settings to the maximum displayed in the Roon Infos but that changed nothing.

I just noticed this now and it really, really annoys me.
I was expecting this to be working out of the box!

Where are the FLAC files stored? Locally on internal disk? smb mounted NAS?

Some HDMI connections are limited 16/44.1or maybe 24/48 for audio.

You could try to use the max bitrate and sample rates to lower settings and see if that helps or use the DSP options to downsample all formats to what is working for you.

I dont have a Denon or any HDMI device I can do a snapshot with as I am traveling this week. but maybe someone would be able to provide that or you could try in the KB area here


Hello @Stefan_Schelm,

Do you have the “Use Exclusive Mode” option in the Device Setup screen toggled on? Due to the way MacOS reports audio devices and their capabilities at the kernel level, it’s impossible for Roon to properly discern what formats the HDMI device actually supports. When Roon requests a report from the CoreAudio API about what formats the HDMI output will accept, MacOS responds with a standard response of 24/192, the max of the HDMI spec.

When you are playing your high resolution files using VLC and the HDMI output on your Mac Mini, you are actually not sending the original bitstream to the HDMI device. VLC outputs through the OS CoreAudio mixer, which will automatically resample audio to the default value of what you have set in the application on your mac called “Audio Midi Setup” which can be found in the Applications>Utilities folder.

If you open the “Audio Midi Setup” app, you may find that it has defaulted to multichannel output at a lower resolution. You may be able to select the option for two channel playback at a higher resolution, depending on your device capabilities.


Hi John,
Yes, I had the exclusive mode enabled. That was one of the first things I did during the initial setup.

Your reference to the midi setup app was helpful, though.
For some reason or another, the format was limited to 44 kHz. Setting it once to 192 kHz and 8ch 24 bit seems to have resolved the issue.
The midi app now displays the format frequency according to the source frequency (I tested it up to 176 kHz).

Thank your your help John.

Two parting points:

  1. The feedback for this situation is not really helpful.
    There was just no sound (even no down-sampling) and no error or warning message whatsoever.
  2. A somewhat related issue: channel layout setting under device settings
    I tried to change the channel layout in the device settings multiple times with no success. I now realise that was probably due to the limitations set by the midi app (just 2ch). Buy after changing it to 8ch in the midi app I still had to make the change twice, as despite hitting save Roon did keep the 2ch after the first try.

Thanks again for the help.
Now, back to enjoying good music.