Hidding Local Albums not working @support

A lot of my local music is lower quality that Tidal music so I have be setting those albums to “Hidden”. With Roon 1.8 they have re-appeared. I looked at the setting and I have “show hidden Albums” to OFF. I have had no success repeatedly gone to the setting for albums and set to hidden. Is this a software problem or am I forgetting something? Example in Pic. Cannot hide non Tidal - Local albums

Computer details.

Core Machine (Operating system/System info/Roon build number)
Asprie TC-895
i5-10400 CPU
Windows 64-bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Google Nest Wifi Router.
Core hooked to network with cable

This is working for me, so check with one of the above …

Edit the album you want to hide and click on Hide Album

Go to Settings > General and ensure Show hidden tracks and albums is set to No.

Thanks for the info. I am already doing both of those things. Just to be sure I have my General "Show hidden tracks to No.

I suggest you try rebooting your core to see if that makes a difference. Otherwise, movve this thread to #support so it’s picked up by Roon staff.

Have rebooted core a few times. Thanks for your time.

1 Like

Issue in 1.8 already logged

I’ve moved this to the #support area for you

1 Like

Hi @Dave_Callender

We are working on this, please see this thread for updates in the future: