HIFI Berry AMP+

Roon Core Machine

Intel NUC ROCK

Networking Gear & Setup Details

Nest Wifi Mesh wifi

Connected Audio Devices

RPI4 with Hifiberry Amp+ hat

Number of Tracks in Library

Not sure but >30k

Description of Issue

I have two rooms in my house that I am using hifiberry amp+'s as roon endpoints. They worked great up until the latest ropieeexl install. Now roon sees them as the same device. I can’t use them both at the same time. It’s like they are competing with each other. They both show up in the audio section of roon settings but only one of them will show as a possible zone in the zone selection area. I have reinstalled ropieee several times and the problem continues. Not sure if this is a ropieee issue or roon issue. Also, I have tried hifiberry os and that worked but much prefer ropieee. Same with volumio.

Going to page @spockfish for you here.

Do both have the same IP-Adress? Maybe both the same static one or one got the IP via DHCP and the other has the same IP as a static one?

Can You access both WebUIs independent from each other?

If not already done set them both to dhcp and give them a unique name


They have different ip addresses and unique names.

I can only access one of the webuis. however they both show up as devices on the webui of the one I can access. Roon also sees them both. I think they are both set to DHCP.

It’s the garage and patio zones I’m having trouble with

This is what I have in roon. Roon won’t let me rename the garage device

The top one isn’t recognized right. The icon tells us that. Did you try to disable it and then restart your core?

… try to shutdown the one you can access the webui and see if the other one became accessible, then check the network setup

@Ben_Haymart Just to check: do you access the webui by ip-address?

I changed the device type for the garage and rebooted the core. This is what I have in roon now.

The patio zone is not showing up even though it is enabled.

shut down the patio one and still cant access the garage webui

i access the webui by typing in the ip address

If a reboot of the garage doesn’t solve the issue I think a reflash of the sd is the best think to do

I would try to start from scratch with the network part. Set both Pi’s to DHCP and power them down. Delete the network leases in your router. Restart the Patio one first and see if it pops up and it’s webui can be accessed. Then the same with the Garage one.

Thanks I’ll give it a try later today.

I had something a while back that seemed similar to this. Somehow I had two Ropieee devices that seemed to be sharing some type of ID. I couldn’t rename them cleanly as you describe.

In the end I re-flashed the SD cards - and set them up again from scratch - which solved the issue.

Would go for a reflash aswell. I think its faster to reconfigure than troubleshoot in this case. It seams a bit, like some service are not working like they should (like the webserver that can’t be accessed). Hope You get up running again soon.

Turns out the 437th try was the charm. reinstalled ropieeexl and so far so good.

2 Likes