Hifiberry DAC+ Pro Continually Out of Synch with Bluesound Node 2

Hello Roon community and @support,

My Raspberry Pi used to stay in synch with my Bluesound Node 2, life was good. But that was a few months ago and many updates since. Now my Pi will drift at least a few seconds per minute so I cannot group it with other zones. The Pi’s timing sounds good when played on it’s own and the Node 2 also plays well on its own.

Any ideas? How do I start to debug this? Thanks!

Endpoints and core are all on wired 1Gb ethernet.

Version 1.5 build 354, 64 bit
Windows Server 2012

Bridge (Raspberry Pi)
Version 1.0 build 164
Linux 4.14.34-2-osmc

Bluesound Node 2
Version 2.16.9
RAAT SDK 1.1.15

Interesting that it has worked up to now, though I still wonder if you’ve now been bitten by the same syncing bug that has affected a number of us for quite a while. It is known to Bluesound and a fix remains outstanding - you’ll find various threads on this forum and clarification on Bluesound’s - https://helpdesk.bluesound.com/discussions/viewtopic.php?f=4&t=4529&sid=cf0c21ffdc1d62d913ad8b440a6ecfa4&start=50#p22163

In the meantime though, maybe a few things to check:

  1. Are any convolution filters disabled for the testing?
  2. It’s worth updating your very out-of-date Node firmware
  3. Have you tried setting the Node as the clock master to see if that helps?

Thanks dhusky.

I don’t have any convolution filters set, I assume that’s what you meant by “Are any convolution filters disabled for the testing?”

As for the clock master, how do I set the Node as the clock master?

I’ve loaded the latest F/W and will test soon.

See under Device settings -> advanced, try setting it to 1 to see if it makes any difference. Yes re. convolution, just ruling it out as some filters introduce time delays.

Edit: Also worth rebooting all devices, including your router and any network switches, if you haven’t already.

Thanks for the advice dhusky but sadly no joy. It worked initially for about 30 minutes then I couldn’t get them back in synch no matter what I tried. Will try again once Bluesound confirms a fix.

Very disappointed in the interoperability of these components of a supposedly premium system.

Hi Gary,

Sorry to hear that - it is curious that it used to work…perhaps @support will have some other ideas to try but I’m not optimistic for you. It is indeed frustrating, particularly when it was first reported to Bluesound at least a year ago.

Hello @Gary_Switzer,

There is a known issue regarding the Bluesound Node 2 and its synchronization behavior while playing as a part of a grouped zone. Bluesound is aware of the issue and investigating a fix.


@john do you know if the new Node 2i suffers from the same issue?

@TreeZorro It’s implied in the thread I linked to above, as I specifically asked whether it would be fixed in both the 2 and 2i…

Ok thanks.