HiFiBerry DAC2 HD /Pi4 will not show in Roon once hostname changes

Hi, I’m not sure if this is the same problem as GregD had earlier (and whether that got resolved) but I have installed Ropieee on a pi4 with HiFiBerry DAC2 HD and cannot get Roon to see it when I change the hostname.

THe first time I flash the SD card and boot up, after I’ve added the HAT details, Roon is able to see the device. But then as soon as I change the host name from ‘ropieee’, it disappears from Roon and I can’t find it again. Even when I swap back the hostname to ropieee, it doesn’t return.

I’ve tried this several times, enabling the zone in Roon first and then changing the hostname and the opposite - in each case, it disappears.

Does anyone know what is causing this? I am using multiple pis so I can’t leave them all with the same hostname but I can’t get this to work.

thanks, simon

Can you send me feedback?


Thanks - feedback is aff220d0acc15625

I have tried a few things:

  1. I found that when I upgraded to XL on this pi, having moved the name back to ropieee, Roon found it again. But then I changed the name and lost it again
  2. I did get another pi on a reflashed card to have Roon find it and I then changed the name and then upgraded to XL. That seemed to work, at least temporarily
  3. I’ve done lots of reboots etc but none of those seems to make much difference

thanks! simon

Also, this feedback ( d08d39d18b63ab39) is another identically set up pi but where I didn’t upgrade to XL. Again, Roon saw it when it was called ropieee but as soon as I renamed it it disappeared. thanks,

I tried the new release - which didn’t resolve the issue.

I did change the name of my DAC2 device, could set it back to the default if that’s a useful test.

Currently working OK with HiFiBerry OS, but have a second SD card - so wast to switch back when needed.

Having similar issue?

One of my pis - with a Pi2AES - stopped working after a reboot tonight (was messing with WiFi settings) and the roon core sees the extension on it (it has a pi screen) and it comes up in Roon’s About screen but I don’t get an audio device.

It has XL


Experienced the same issue tonight with identical configuration - Pi4/DAC2 HD. Roon doesn’t see it as an output device, although it shows up in the “About” listing in the Roon menu. It disappeared after the latest Roon update )1.7/710) and 3.015.

It’s late so I haven’t tried burning a new image on an SD card, will try that in the AM to see if it restores operation.

Any ideas? TIA, Tom


There seems to be a problem with the Hifiberry devices and the 5.4 kernel (which is being used by the latest RoPieee).

I’m preparing a fix and will release a beta later today that might solve that issue.
Stay tuned, I’ll poke this thread when the beta is available.



You can try to change your HAT config to the “Allo Digione”.
That might solve your issue.

Let me know how that goes.


Nope, still doesn’t show up.

My other Pi2AES device is working perfectly shrug

Ok then wait for my fix later today.

@simon_bones, @GregD, @TommyD , @Taverius,

I’ve pushed out an update to the beta channel wrt Hifiberry devices.
@Taverius this might also solve your issue.

Can someone test this?

If it fixes the issue I’ll release a stable version ASAP.


Not for me, I tried both Pi2AES and Digione and also setting host name to ‘ropieee’

Sent a feedback with the beta, f7f5d02f7b67e44d

Keep in mind: your issue has nothing to do with host naming.
Your HAT is just not properly initialised.

Have you checked the contacts? Is it properly mounted?

sorry - how do I access the beta version?

It’s mounted in the same case it has been for months now. With the proper standoffs and all.

And the whole thing is being powered from the Pi2AES so it’s definitely connected.

Go to the ‘advanced’ page on the web interface of RoPieee.
There’s a field labelled ‘update channel’. Put that on beta and follow the instructions.

(it will configure, ask you to reboot, on which you will be presented with a ‘update available’ message).


Can you provide feedback with the ‘RPI-DAC’ as HAT selected?


Sure, c14d96e375b05214

Oh and I have an audio device showing now.

I have tried with beta and the device is still not showing on the ‘audio’ tab. However, it does show on the ‘About’ tab under Roon bridge. Feedback is f8c9c02a85b63280