HiFiBerry Digi+ PRO no show

Hi all.

I’ve been using this wonderful piece of software for a while. I have two ropieees up and running. One with USB connection to a DAC. One with a Hifiberry HAT with analog output and they both run smooth.

My issue right now is to bring my third one up and running. RPI3 + Display + HiFiBerry Digi+ PRO.
It all looks ok from the web interface however the unit does not show up on the “audio-console” on Roon.

dmesg says the following:
[ 5.167202] snd-hifiberry-digi soc:sound: ASoC: CPU DAI (null) not registered - will retry
[ 5.170418] snd-hifiberry-digi soc:sound: ASoC: CODEC DAI wm8804-spdif not registered - will retry
[ 5.326062] wm8804 1-003b: Failed to read device ID: -5
[ 5.330548] wm8804: probe of 1-003b failed with error -5

Is the card broken? I’ve tried both Digi+ and Digi+ PRO but with same results.


Some troubleshooting here:

Hmmmm… that doesn’t look good.
Those ‘not registered’ can’t harm, but that ‘failed to read device’ is not good.

Have you tried removing the HAT and butting it back again?

I had the same issue solved in this way: you have to start first the Roon core. After that you can power on the raspberry pi. After the boot procedure the raspberry network audio player appears as an audio zone (if the raspy is configured correctly eg. proper HAT, proper ip address).
If you activate the raspberry before Roon application it cannot detect it.

The strange thing is that the player does not show up even if I reflash it and add a USB DAC.
Where to start debugging?


Yeah well the logging above doesn’t look good. Is that message still present after unmount and mounting the HAT again? Because if so then I’m afraid it ends there.

Well i tried with the USB DAC (an iFi that works ok with my other player).
It shows up as a device with lsusb but not as a player in Roon.


Oh ok. I didn’t understood your remark about usb anyhow. Can you send me feedback? Go to the webpage of your RoPieee, then to the ‘advanced’ tab and hit the ‘send feedback’. I can then have a look in the logs. Please do so with the USB DAC connected.

I assume you enabled USB in the webpage right?



OK… I found a problem. You didn’t had an ethernet connection while installing RoPieee. That is required because the Roon software is being pulled from the internet during installation.

As you already know how to run a dmesg I suggest you log in and run the following command:


After this reboot and try again. USB connected DAC should show up in Roon.

Yeah, that worked.
But still the error on my HAT :frowning: I guess i need to get another one.
Anyway thanks for your support!


@spockfish New HAT same problem :((((
I will try another RPi

@Tomas_Prybil Djeez…

Before you do that… Can you log in and add the following line:


to the file


And try again?

too late :slight_smile:
i didn’t have any more uSD cards so needed to flush the old one.
New RPi with old HAT works
no more errors in dmesg and the player shows up in Roon

Ok… so you’re Pi seems to be the problem.
By any chance; are you using a different power supply with this other Pi?

Its a 2,1A Apple USB “charger”, I could change that if you like.
I will check the “old” RPi again later on when I get another uSD card.



Well, would be great to figure out what the cause was.
I was thinking that it could be a power issue (lack of) with the HAT attached.

ok, i will report back when I have the possibility.

To bother you oncemore the RP is up and running, but the display tab is not shown in the web configuration page. The display is working ok, but just as a std display.
Where to look this time?

Current build is 099

And you reinstalled from scratch?

Because the display tab missing means that RoPieee did not detect the touchscreen.

I started out without the screen just for fault isolation.
I could do a reflash with the display attached.