HiFiBerry Digi+ Pro - Recognized by Roon Core but doesn't play [Resolved - New Router]

Tony, thanks for the link.

The analysis it’s ongoing but is really slow even with “4 cores” setup.
As far i understand even if the analysis is not completed the file can be played?

I also noticed that the analysis is repeated from the first file as soon Roon is shutdown and restart. It’s that normal?

I noticed that because 2 times happen that the screen become “white” and I need to restart the application.
I don’t remember where I read, maybe in this forum, that someone have a similar problem… I will check

Yes. Analysis computes the waveform in the play bar (it will be absent if the file it not yet processed) as well as the Dynamic Range value. But sure – you can play all tracks while analysis is still going on.

The analysis process just picks up from where it was when Roon was shut down.

The first run (when Roon is analysing all of your files is quite intensive. You can turn it off temporarily if you want to play with Roon now (this will also give a clearer view of the problems you encounter with your Pi). Just turn it back on when you are not using the computer – or let it finish overnight (or over a few nights… ;-)).

Thanks Rene for your reply… good to know that I can stop it :slight_smile:

Unfortunately this doesn’t help to solve my problem…

I can use Roon with another dac through wasapy, not in the network but connected directly to the pc. Look like is a problem with the network connection?

When you tried attaching the server directly to the router, did you disable WLAN for your trials? I suppose the WLAN configuration on the Pi3 is also either unconfigured or disabled?
Agree that it seems like a networking issue…
Cheers /Mike

Hi @enrico_calzona ----- Thank you for the report and sharing your feedback with us. Both are appreciated!

May I kindly ask you to verify the following information for me:

  1. Please provide the details of your network configuration/topology, as well a providing insight into any networking hardware you are implementing. I want to have a clear understanding of what the chain of communication looks like across your network.

  2. Can you please confirm that you don’t have any active firewalls or antivirus applications running on your setup.

-Eric

Also make sure JUMBO FRAMES is OFF - can’t say for sure thats the issue but its worth checking

Thanks to all your reply and supports… really appreciate!
I will check and reply tonight when I back home (I live in Korea and we have 7 hours difference with europe)

What I can say right now is that the WLAN is disabled and reading the link regarding the “JUMBO FRAMES” look like that should be a good solution to my issue…

Thanks again and Regards,
Enrico

Hi Enrico,
I spent some months trying to fix a similar issue only to find out that the problem was in an HP switch (Can't play HiRes file on my network (Audio file loading slowly) [Solved]). My suggestion is to check well the compatibility of all your network devices with ROON.
Best regards,

Hi @Eric,

Thanks for your reply… regarding your questions:

  1. My LAN right now is very simple. I have one router (model KT_WLAN_B75A) with my PC and the HifiBerry wired to the router.

  2. the Windows firewall is OFF and I just disinstalled the Bitdefender

Best Regards,
Enrico

Hi @wizardofoz,

Unfortunately the Jumbo Frame setup was already disabled. I tried to set at 9K (as I read in the thread you sent me) but doesn’t solve. As suggested I back disabled anyway

Best Regards,
Enrico

Hi @Giulio_Salvioni

Thanks for your reply… unfortunately I don’t have the skill and knowledge to check the compatibility as you suggest.

I just hope that with your support I can finally enjoy the Roon :slight_smile:

Best Regards,
Enrico

My first attempt would be to connect the PC to the LAN with an Ethernet cable.
Best regards,

@Giulio_Salvioni,

The PC and the RPi are actually connected to the LAN with the Ethernet cables.
As I said above the LAN is quite simple, one router, the PC and the RPi connected with cables

You mentioned Bitdefender, can you try turning that off, as firewalls can interfere with Roon

Ok, could you try with a different router? Or insert a GB switch to connect the PC, the RPi and the router? In this scenario the router should have only the role of access the Internet and wifi enabler.
Best regards,

Hi @Matthew_Clegg, the Bitdefender has been disinstalled and the Window firewall is OFF

Hi @Giulio_Salvioni , I don’t have another router and a GB switch as well… anyway the problem is the LAN and 99% is the router. Following your thread I read that you mentioned one time to connect directly the PC to the RPi. I tried right now and the RPi/HifiBerry is playing :slight_smile:
I one side I am happy to know that the whole system CORE + RPI is working but I need anyway to solve the problem of the router that will be very difficult. I tried 2 years ago to access to the setup for other reasons and the web application is ONLY in korean… really frustating :frowning: The problem is that in Korea the router manage not only the wifi but even the TV and I can change it with another brand…

Just to confirm your MTU should be 1500 to ensure no jumbo frames

Ok, the solution could be to try with an affordable GB switch like the one I’m using in my home network (Netgear GS108T-200GES Switch ProSAFE Smart Gigabit (62,00 € on Amazon) or even a smaller one. You could connect your PC and RPi to this switch and the switch itself to a free port on the router.

Thanks Giulio,
Actually I was thinking to keep the Korean router only for the TV and buy another router for the rest of my lan including wifi connected to one port of the existing one… I am not an IT expert but you think will work?

No, this is not a good idea. Keep your existing router and let it act as the DHCP server and wifi access point. You only need a “stupid” but reliable gigabit switch (Netgear is my advice). Assuming that you’re not an IT expert I suggest an unmanaged gigabit switch which is btw cheaper than mine.
Best regards