High CPU & GPU usage on MacOS

Core Machine (Operating system/System info/Roon build number)

iMac Retina 5K, 27 inch, 2019
Processor 3.6GHz 8 core i9
Memory 64GB
Graphics Radeon Pro Vega 48 8 GB
SSD 1TB
macOS 10.15.4 (19E287)
Roon 1.7 (build 537)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Hitron cable modem and 550Mbps/35Mbps fibre broadband
Ethernet connection

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Naim Mu-so QB 2nd generation
Ethernet connection

Description Of Issue

Roon runs well from cold start up of the computer, then after about 4-5 hours gets trapped in a loop where it takes up to 60% of the CPU and 99% of the GPU. It’s obvious that it’s happening as the fan spins to maximum which almost never happens - even when using power hungry applications like Photoshop and Final Cut Pro. A reboot of Roon starts the cycle again. I hadn’t noticed the problem before the current build. Screenshots show “normal” CPU & GPU usage.

1 Like

something simmilar happens on macbook pro 15" too - gpu with MacOS 10.14.6 Mojave - usage (either intel or amd radeon - whichever is in use) steadily goes to over 50% and consequently fans kicks in and machine gets got in few minutes with battery life going quickly down.

I have noticed that it’s happening every time when this specific animated element is displayed on the screen:

roon-macos-gpu_load

Once I go to other section of roon, like for e.g. “Overview” the gpu usage goes down to normal (10-15%)

hope this helps to isolate the problem

@Daniel_Coe we have the same issue please check macOS Catalina interface laggy randomly while running Roon (High GPU usage randomly, Roon idle 20% GPU, sometimes up to 99% usage)

Same iMac gen as well.

I’ve had Roon playing in the background while I work - I’m just using Chrome and Mail - so nothing intensive. After 2.5 hours the fan has suddenly come on to full and Roon is hogging resources. Why?

Roon has kept the fan spinning at maximum for 7 minutes so I’ve quit Roon and the fan has stopped immediately. Nothing on the computer is now using the GPU.

Immediately on restart Roon has grabbed all of the GPU and the fan is on maximum - it’s kept that up for 37 minutes.


I’ve rebooted the computer and restarted Roon. Usage is back to normal

I’ve played one track, fan has come again so I’ve pressed pause and Roon is still going crazy.

Please can somebody from the Roon Development Team respond?

Thanks

3 Likes

@Daniel_Coe we have the same issue check this out: macOS Catalina interface laggy randomly while running Roon (High GPU usage randomly, Roon idle 20% GPU, sometimes up to 99% usage)

@support is working on mine, hope they will see yours as well.

2 Likes

Hello Everyone,

Please see Dylan’s update regarding this issue here:

Hello,

I just experienced the same issue with version 1.7 build 667 on Catalina today. 2020 Macbook Pro running Catalina.

I just wanted to see how the progress is coming along on fixing this.

Thanks! Really loving this software!

I sometimes experiences high GPU usage. I find that it gos away if I restart Roon. Not the best solution but I hope it helps. I have a MacBook Pro 13 2017 with Big Sur.