High CPU Usage for Roon

(Maor Avni) #1

Core Machine (Operating system/System info/Roon build number)

I7, Win 10 1809, Roon 416

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Corporate Network. Can’t really tell.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Centrance DacPort through USB.

Description Of Issue

My Roon app takes up 10% of the CPU just sitting there. The library is completely scanned and analyzed, so none of that is happening.

After opening the app and waiting for folder rescan to complete the CPU settles around 10%, without playing.


image

(Noris) #3

Hi @maoravni,

Thanks for reaching out here. There are lots of things Roon can be doing in the background during idle, like retrieving updated metadata for all your albums.

Just keep in mind that the Roon Core is designed to be reasonably “heavy” so I wouldn’t get too hung up about resource usage, unless it’s causing other issues.

Are you experiencing any other symptoms? Dropouts? Slow performance in Roon? Resource problems with other apps? It’s ok if you’re just wondering about the numbers, but these don’t look concerning to me.

– Noris

(Maor Avni) #4

I have Roon installed for more than a year. I have never witnessed this CPU usage.

This is a relatively new install - It’s my new work laptop which I use to listen to music at the office.
I have it installed on two other machines - one is a Core2Duo (Yes, I know. It’s old. Still) Windows Server:

The other is my desktop at home. I’ll have to wait until it rescans and reanalyzes all library changes as it hasn’t run Roon for a long time. Then I’ll be able to upload the CPU usage for that i7 Win 10 machine. But I’ve had Roon installed on it for a long time and it has never shown that CPU usage.
I’ve been keeping track on the CPU usage of Roon on that i7 machine, as it’s a mini desktop machine. The machine is completely silent at idle and fans rotate faster as the CPU usage increases - I’d be aware of normally high CPU usage on it.

Is there some way to query logs and find out the cause?

One key difference though - my work laptop runs standard Roon, and the other two machines at home run the server. The client can be used on multiple devices - phones, desktop, laptops, etc.

(Noris) #5

Hi @maoravni,

Thanks for letting me know that info.

This could explain the difference here. Since the standard “All-in-one” version of Roon has a GUI, it is also implied that it will use more resources. There are also a few other aspects to check here:

  • Do you have any tutorial bubbles active? If so you should click all of them to see if it helps
  • Is there currently an “activity spinner” present in the top right-hand corner of Roon? It looks like this:
    image
  • Have you tried rebooting the work Core? Might help.
  • Since this is a new install, maybe Roon is still fetching metadata updates in the background, try to see how the performance is like after a few days.

Regardless of all the suggestions above, I would still not worry too much about the usage here since as I mentioned Roon is designed to be relatively heavy, with background activity.

– Noris

(Maor Avni) #6

image

No. Still no CPU activity. This is on my home desktop.

The problem with the high CPU load on my work machine, is that it makes my machine a bit sluggish. Add that to the general sluggishness of the machine because of over protective IT guys that install several kinds of anti virus scanners, it makes my machine hell to work on - I’m a software developer, and compiling C++ on it is very slow.

As to your questions, there are no tutorial bubbles that I’ve seen and no activity spinners. The CPU usage count screenshot is taken after a reboot and after Roon finished rescanning the storage folders.
The screenshot on the desktop was taken while the Roon UI is open, so no irregular CPU usage there.

(Maor Avni) #7

To eliminate the corporate firewall/network environment, I’ll take my USB drive home tonight and monitor the CPU activity again at home.

Still, is there a way to enable debug logging to make sure that this is normal Roon activity?

(Maor Avni) #8

Still at work. Will try the network at home later.

I’ve deleted the configuration. Now It’s a clean install. No music. No tidal. No audio devices connected.

Still ~10% CPU usage.

(Maor Avni) #9

Update:

Connected my laptop machine at home. Same configuration - clean install.

CPU usage is as expected - 0%.

Restoring the entire configuration back I still get 0% CPU, so it’s not the configuration.

I tried going over the logs, but couldn’t spot anything suspicious. Anything else? Or am I doomed to use Roon at constant 10%?

My problem is that it actually interferes with my work and constantly slows me down while listening to music.

(Noris) #10

Hi @maoravni,

CPU usage won’t really show up in the logs and since it is a Core2Duo, the CPU is a bit under-spec’d. I wonder if you try using RoonServer instead on your Work PC, does that change anything? You can of course use the current Roon “All-in-one” package as a Roon Remote and have it connect to the RoonServer instance. I would give that a try to see if it helps.

– Noris

(Daniel Beyer) #11

I would bet a beer it is some interaction with something they installed and Roon.

(Maor Avni) #12

Got to work and first thing checked the server installation.

Guess what? same thing. The server now uses a constant 10% CPU.

This is a clean installation again - No music, no audio devices configured, no streaming services.


(Maor Avni) #13

Digging a little into the logs I grepped this:

06/10 11:02:45 Trace: Successful POST response from https://push.roonlabs.com/push/1/connect
06/10 11:02:45 Trace: [push] connecting to 34.74.77.98:9200
06/10 11:02:45 Trace: [push] connected
06/10 11:02:46 Trace: [push] restarting connection (Unable to read data from the transport connection: A blocking operation was interrupted by a call to WSACancelBlockingCall.)
06/10 11:02:46 Trace: [push] retrying connection in 97867ms
06/10 11:02:57 Trace: Successful POST response from https://push.roonlabs.com/push/1/connect
06/10 11:02:57 Trace: [push] connecting to 34.74.77.98:9200
06/10 11:02:57 Trace: [push] connected
06/10 11:03:16 Trace: [push] restarting connection (Unable to read data from the transport connection: A blocking operation was interrupted by a call to WSACancelBlockingCall.)
06/10 11:03:16 Trace: [push] retrying connection in 79521ms
06/10 11:03:26 Trace: Successful POST response from https://push.roonlabs.com/push/1/connect
06/10 11:03:26 Trace: [push] connecting to 34.74.77.98:9200
06/10 11:03:26 Trace: [push] connected
06/10 11:04:35 Trace: [push] restarting connection (Unable to read data from the transport connection: A blocking operation was interrupted by a call to WSACancelBlockingCall.)
06/10 11:04:35 Trace: [push] retrying connection in 52231ms
06/10 11:04:45 Trace: Successful POST response from https://push.roonlabs.com/push/1/connect
06/10 11:04:45 Trace: [push] connecting to 34.74.77.98:9200
06/10 11:04:45 Trace: [push] connected
06/10 11:06:45 Trace: [push] restarting connection (Unable to read data from the transport connection: A blocking operation was interrupted by a call to WSACancelBlockingCall.)
06/10 11:06:45 Trace: [push] retrying connection in 53755ms
06/10 11:06:55 Trace: Successful POST response from https://push.roonlabs.com/push/1/connect
06/10 11:06:55 Trace: [push] connecting to 34.74.77.98:9200
06/10 11:06:56 Trace: [push] connected

Does this ring any bell?

(Maor Avni) #14

Tried another thing: disabled all network devices, disconnected wired ethernet and connected to the internet using my phone as an access point. CPU usage went down to 0%.

Connected back to the infrastructure: CPU usage went back to 10%.

(Geoff Coupe) #15

Your IT folks have probably blacklisted Roon cloud services :slight_smile:

(Maor Avni) #16

That was my suspicion.

But the funny thing this is the only connection that is being blocked. All of the other traffic to Roon cloud services to download metadata and such is being passed fine.

This brings me to other questions:

  1. Can anyone tell what that IP and port used for? If I want to whitelist this I’d need exact information.
  2. Why is an IP used instead of a DNS name?
  3. The connection fails. The connection is retried constantly with random intervals between retries. Roon takes up 10% CPU until the connection is successful. Isn’t it a bug?
(Noris) #17

Hi @maoravni,

Thanks for the update here! It does seem strange that without the network connected the CPU does not display this behavior. I’m not able to answer those questions, but I’d like to gather some more info and ask QA to take a look:

  1. Can you note some timestamps of when this issue next occurs and let me know a few timestamps?
  2. Can you send me a manual set of logs from that Core by using these instructions?
  3. If you by any chance have another machine with similar specs on the same network, does it behave in the same way?

– Noris

(Maor Avni) #18

https://zerto-my.sharepoint.com/:f:/p/maor_avni/EmM5P2j4UW9EiKFmaOeO6iYB7xDAsNJ5Mhop1pOaB2Z0tQ?e=seahgK

You’ll find the logs there. I’ve put a readme.txt file inside the folder to describe the timeline.

(Maor Avni) #19

There’s also a zip file in the folder.

(Noris) #20

Hi @maoravni,

Thank you for sending those logs over, I have asked the QA team to review them for any interesting traces and will let you know once I hear back. Still, the best way to address issues such as these is to get them reproducible on our end.

While we wait to hear back, it would be interesting to know if you are able to modify any aspect of your home network to provide similar results as your work network while using the same Core machine. If you temporarily use a similar firewall rule in place on your home network, does the same issue occur, or is it limited to just the work network? Are there any other high-level details of the work network that you can share with us?

– Noris

(Maor Avni) #21

I will try. I’d need to know what is blocked though.

Is it the https request push?

Is it the 34.74.77.98:9200 access?