High CPU usage on Big Sur

I am having this problem - making Roon almost virtually unusable on my Mac (2017, 5K iMac, running Big Sur 11.0.1).

Am using my mac in remote mode to control Roon on a NUC server - but it explodes to 260 %CPU, and fans going crazy, as soon as I open it.


that sucks… it got “fixed” for many of us… have you considered a clean install? kind of bluffing but may help ! ?

Hi @Barney_Hamilton,

Can you share some screenshots of the resource usage?

Did this happen for you before the Big Sur update?

If you reinstall Roon on this machine is there any change?

My problems only just started. It uses ALL of the 8cores, leaving 1% unused. The wifi thing doesn’t work more than once. I have left the machine on all night and is till on because I was using dBpoweramp to find album art. I didn’t know it was going to hunt down files!. I have 19000! But know many are dups. Haven’t had the time to sort it yet.

I am appalled to find this problem has been known about for too long a time. I own the lifetime version so I am stuck with having to use a buy a Windows machine.

Not a happy bunny with Roon by a long way. I have waited about 6 mths now for them to tell me why two tracks off on album will not play.

For a program that is so expensive, this is just not acceptable. I love the program but right now it isn’t really usable. That is unacceptable.

EDIT: have not updated to BIG Sur as I am afraid to. Catalina lost me a very expensive program so I am loathe to face that again.

There must be something really strange going on. My MacMini i7 (2018) runs 24/7 and never ever did this. It runs only RoonServer, not Roon. Here a snapshot from what"s going on. One stream only, but with say 3 streams it’s still more than. OK.

Time machine could help with your fear to upgrading…
I had the same problem. It never happened again since upgraded to Big Sur, no idea why but has to do with macOS network stack, prove is I could not do any Qobuz streaming when in Catalina Core, the tracks will skip every 20 seconds or so… out of curiosity I tested after the Big Sur update, since then Roon has never skipped a Qobuz track.

Hi Dylan - it happened both pre and post Big Sur. Reinstalling Roon didn’t make a difference. However, now I have unplugged my ethernet connection, and run my Mac on wifi only, connected to my ROCK core, the CPU usage on my Mac is only 8% and fan drops to quiet. Just updated to 1.7 build 710, and seems to be ok (keeping on wifi)

1 Like

Time Machine is not recommended as restore option for roon…so if you go back then you should do a roon backup to other media then restore that backup when you have gone back to whatever MacOS you prefer. I always turn all Mac updates off and only do the security and app updates until I know its safe to go to the next OS versions. I’m still on Mojave for may main use. Roon I run on a dedicated core machine or Nucleus.

I am talking about his fear to upgrade the OS, not even considering time machine as Roon backup option.

I know, but some will still Bugger up roon with a time machine restore don’t you worry.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.