High CPU Usage on Mac Mini 2018

I haven’t read all of this but have the same issue. Mac Mini 2018 i7 32G ram. CPU is usually less than 5% when idle, usually closer to 2% with 1% user and 1% system unless backing up or the like. , Running Roon in client mode (server on a Zenith)

When I start Roon both user and system go to 20-25% for a total of around 50% CPU. The fans kick up from 1700 to 3600 and CPU core temps go from in the 40s up into the 80s and 90s. . One reason I got a server was so I would not hear the fans but that hasn’t worked out. It is ridiculous that Roon requires so much processing power just to be a client.

What has worked for me the last few times this happened (a while ago now) is to reboot the Mac.

Roon on the Mac is crap. I experienced all the above issues for about a year. My Mac was getting very hot and out of control. Even hotter than with video rendering. A NUC8i7 was the solution and I can use my Mac for regular business, without getting stressed. My Mac is a 2012 i7 quad core 16 GB Ram.

:pray: John

1 Like

thank you Paul, a reboot dropped usage to a few %… so that begs the question… is it a Roon issue or a MAC issue? but at least I have a work around.

Gotta be a Roon issue, in its interaction in certain API calls in MacOS. Never seen anything remotely like it with any other piece of software…

Unsure what it is. But I have a 2020 MacMini running 24/7 as my Roon Server. No issues found so far. Runs cool & quiet!
Loaded on it is Roon Server (I kept it minimal) not the full Roon, as it’s just a server running headless. When needed I use Remote Access on my MB-Pro to approach it. The music files reside on a Thunderbolt drive (LaCie).
The Roon database is on the MM (on its 256 GB internal SSD).

Weird, isn’t it?

By the way, it’s the 16 GB RAM i7 version. Latest OS always. No other software running apart from what the OS needs, plus of course what’s needed to approach it via sharing. I let Roon upsample everything to Double DSD, and it’s always doing that at c. 10x speed.

Not that weird, the issue comes with the Roon client (interface) you are running it headless as background service. Do the test, install the Roon interface, start using it, then you will see…

well, I was at a very low % after a reboot and Roon has slowly crept up to where I’m at 50% total again…

Roon need to fix this problem

OK, so I may be lucky (?) to run just Roon Server. That does then also mean that the issue must be outside the server function. Now, I know that grahics-heavy applications (like movies, games) sometime are very heavy on the CPU (meaning they are badly written, they need to hand this off the the GPU). Could this be an issue with Roon?

Have you tried to install & run only the server part, so not the full package? Is a download option when you get Roon.

Hi everyone

First, I’d like to say that we appreciate your patience as we’ve continued to investigate this issue. After gathering data from a number of reports, as well as our own testing, we’ve traced this issue to a specific chip that appears to not be handling Roon how we’d expect.

While we don’t have this resolved just yet, our QA team is in the process of acquiring this specific hardware for further internal testing in our labs. With this specific hardware in house, we believe we will be able to see first-hand why certain devices are not reacting to Roon the way we’d expect and can then get a report to our development team to resolve the issue.

Hardware-specific issues like this can require some in-depth testing to fully understand, so we can’t offer any specific timelines just yet. With that in mind, we want to assure you that this is a top priority for us. We want to make sure that we get this right, and we know it’s already taken longer than anyone would have liked.

The team remains confident that bringing this hardware in-house will be a big step toward getting this resolved, and we will be sure to keep everyone in the loop as soon as we have further information on this. Thanks again for the patience you’ve shown as we work to resolve this, along with the great details you’ve all provided to us to aid in our investigation.

Roon Technical Support


Thanks for the update, this would be greatly appreciated as It’s still an occurrence for myself as well sometimes.


Still experiencing this for quite a while on my 6-core i7 2018 Mac Mini. UI client only – core is running on a separate linux host. It seems to be consistent and easily reproduceable here. Love the Roon service, but this has been a continuous thorn.

Perhaps this thread provides a list of customers where you can help verify/correlate/observe this issue. I’d be happy to assist in any troubleshooting you need to do for verification, and I suspect others here would be happy to do the same.


Thank you for this detailed update, Your candor and transparency certainly helps. Most of us understand that these issues are often tricky and need to be replicated to be properly addressed.

I hope you can continue to update us a to your progress.

I have the same issue on iMac 2019

MacOS 10.15.5
iMac 2019 (Core i9 9900K/40 GB RAM/NVME SSD)
Roon 1.7 build 555

Thank you, I appreciate your efforts.

Roon UI just auto-updated on my iMac 2019 running Mojave (10.14.6) to build 571 - and CPU usage spiked again, at 420% according to iStat Menus.

Reboot, and presto - CPU usage back to the usual few %. It’s always the same thing…

My Mac mini is connected via ethernet. I used to leave wireless on to facilitate apple watch unlock etc.

Since turning wifi off the problem rarely occurs. When it does, turning wireless on, then off again usually fixes it without a reboot.

I leave wireless off most of the time now. I’m pretty sure even if you leave wireless on, you can turn it off and on again for a similar effect. For those of you also suffering through this, playing with this just might save you a reboot. Its not a fix, but it might help - if it does, it’s waaaaaay better than closing everything and rebooting.

Sounds like Roon are getting closer to finding and fixing the issue.

Mac OS 10.15.5
CPU usage over 300%.
Roon 1.7 build 571
Roon not playing anything.

try turning off wifi assuming you have an ethernet connection…this does seem to help

1 Like