HIRES files ROON via Raspberry Pi 4B

Good morning,
Setup: Roon Nucleus(with external HD for HIRES musical files) + Raspberry Pi 4B (+ Volumio and USB pendrive with selection of HIRES musical files copied from the ext HD) + external DAC/preamp(McIntosh D1100).
Plugin Roon Bridge installed on Volumio.

  1. OK. If I use only Roon Nucleus (core + endpoint) directly connected to the dac of course all is ok. I see on the DAC display the right sample rate. (both PCM and DSD)
  2. OK. If I use only Pi (with Volumio) with HIRES files on the USB pendrive it sends the files up to 352Khz
  3. KO. If I use Pi as Roon endpoint the same HIRES files are always downsampled 44.1KHz.

I don’t find any ROON or VOLUMIO paramether to modify for solving the problem.
Anyone can help me? Many thanks
Best
manuel

Hi @texx_mt,

Can you share a screenshot of the Signal Path when playing to this endpoint?

Thanks!

  1. OK. If I use only Roon Nucleus (core + endpoint) directly connected to the dac of course all is ok. I see on the DAC display the right sample rate. 176.2Mhz and DSD 64. All is ok so it’s not useful attach pictures
  2. OK. If I use only Pi (with Volumio) with HIRES files on the USB pendrive it sends the files up to 352Khz. Maybe it converts DSD on PCM (with a bit downsampling) but it’s ok

  3. KO . If I use Pi as Roon endpoint the same HIRES files are always downsampled 44.1KHz.


Let me know if all is clear
thanks
manuel

You stream to your Raspberry using AirPlay which is limited, not Roon’s RAAT protocol. If you have installed Roon Bridge on your Volumio OS you should be able to enable the RPi device with RAAT protocol in Roon’s device setup.

One other option is to use RoPieee (not RoPieee XL) on your Raspberry which includes Roon Bridge and doesn’t support AirPlay, so RAAT streaming is the only (and best) option.

Sounds like Roon bridge is not running on Volumio or you just added the wrong source in Audio settings as that’s Airplay not Roon bridge sending to the pi.

Roon will see Volumio‘s Roon Bridge only when Volumio is idle. If Volumio plays anything, the Roon endpoint is invisible. If you stop playing, you may need to rescan the Volumio from Roon (with the small redo symbol shown next to the Raspi symbol in Roon.)

@Andreas_Philipp1 many many thanks.
I’m in the raspberry world since two days and … I really don’t know anything. I’ve just been able to assemble the Pi with its case, flash volumio on the sdcard, install volumio on my tablet, connect the Pi to my home net and few other parameters. It works but … I’m starting (slowly) to go into.
I’m quite sure that Airplay has been not my voluntary choice. It’s there; I can see it but I think it’s a Volumio choice. Tomorrow I will try to ask to their support.
If you want … please, tell me more about RoPieee. I just visited ( https://ropieee.org/getting_started/ ) but … it’s not clear for me how to add Ropiee to Volumio, or replace it. For example they say " Make sure the Raspberry Pi is connected to the internet!" but I don’t know how can I do it without Volumio on my tablet.
Her a screenshot of an old discussion on this community

@Cristalgipsy many thanks you too. I attach 2 screeenshot. I absolutely believe that I did something wrong but … I don’t know what.
Screenshot_20201202-210538
Screenshot_20201202-213309

Hi Manuel, you’re welcome. If your goal is to use your Raspberry Pi as Roon endpoint, my suggestion is to not use Volumio at all, but flash RoPieee on your SD card and set up your Pi with this. It’s easier that way. RoPieee is just a minimal Linux distro with Roon Bridge preinstalled.

When you boot your Pi for the first time with RoPieee, it must be connected to your router by means of an Ethernet cable. It needs Internet access for this first boot. Afterwards you can use RoPieee’s web setup to configure WiFi for the Raspberry, if you like.

There is an excellent beginners guide how to set up and configure RoPieee:

It happens that the Roon bridge does not install correctly. It is a long download and install. Try deinstalling it. If that worked, then it was installed correctly. Volumio and Roon makes only sense if you use the HDMI out. Otherwise other packages might be better.

Andreas and Joachim many thanks for your time and your patience .

Good clarifications for me:
One other option is to use RoPieee (not RoPieee XL) on your Raspberry which includes Roon Bridge
Volumio and Roon makes only sense if you use the HDMI out. Otherwise other packages might be better”.

Tomorrow I will follow your suggestion and I will (try to) install RoPieee.

Joachim, please let me understand better (with the small redo symbol shown next to the Raspi symbol in Roon.) . May you attach a picture for me?

Thank you guys
manuel

Download RoPieee or RoPieeeXL from their website to your computer. Burn the RoPieee software to a microsd card using Etcher. Insert the microsd card into your Raspberry Pi. Connect the Raspberry Pi to an ethernet connection. Plug in your power supply. Wait for RoPieee to install. Find the ip address of your RPi. Use your computer browser to find that ip address and go into the RoPieee settings and make your selections.

Wow, great :grinning: I did it.
Tank you my friends for helping me.
RoPieee send the right sample rate to my dac. It does exactly what I need.

Maybe, in the future, I would like to try a HAT like HiFiberry Digi+ pro or Allo DigiOne Signature for link the dac by S/PDIF. Anyone experienced?
Many thanks in advance
best
manuel

2 Likes

Well done Manuel!

1 Like

I like the Allo DigiOne. Never bothered with the Signature as the base model is so good.

2 Likes

Another well-regarded option for S/PDIF out of RPi is the Pi2AES Pro Audio Shield. It is supported by RoPieee.

1 Like

If you use SPDIF out to your McIntosh then you’ll be limited to 192kHz sampling rates and resampling of DSD to PCM. USB on the McIntosh D1100 goes up to 384 kHz and supports DSD.

I have a McIntosh C48 which has an older built in dac than what you have. I also have a raspi dac hat and a spdif output hat. In my experience I couldn’t hear any difference between SPDIF and USB to my McIntosh. I have Chord Qutest dac as well and I can’t hear any difference between the McIntosh dac and the Qutest. You may have a difference experience but I’d stick with USB input and I’d be confident that the McIntosh dac is going to sound pretty much as good as any top performing well designed dac. You have a terrific set up.

1 Like

@Rugby @Andreas_Philipp1 @Douglas_Gardner many thanks for the suggestions.
Also this point is very important to remind me an important thing

In any case, even my Pi is “born” to be used in a outdoor minisystem without any kind of audiophile expectations, I’m a curious man and I would be happy to know more of its potential capabilities. This is the main reason.
Moreover, just for fun, I would like to compare the Nucleus with the Pi but my D1100 has only one USB input (of course dedicated to the Nucleus).
So, I need an S/PDIF (rca) out for my Pi and I could do the comparison (at least with PCM files).

Daniel says: Allo Digi One
Andreas: PiAES Pro Audio Shield
Douglas: which HAT are you using?
me: I know HiFi Berry Digi+ Pro

A lot of fun :grinning:
best
manuel

I have a HiFiBerry Digi+ Pro that I was playing with for SPDIF and Coax. I also have Squeezebox touch. I can’t hear a difference between SPDIF, Coax, or USB using either SBT or Digi+. You’re right that using a hat is a good way to test how these paths sound. Be sure that you are feeding the same track and format through each channel and make sure you level match. If using Roon make sure the any sample rate, DSP, or EQ settings are the same too. On my McIntosh C48 I can configure different inputs to use digital 1 or digital 2 in so I have USB going to the dac, and Digi+ coax to digital 1, Digi+ SPDIF to digital 2. In Roon I group the McIntosh dac and pi HAT so they play the same track in sync and you can switch quickly between these sources on the McIntosh.

If there’s even a .5 db difference in one of the delivery paths then you may hear a difference because of volume difference instead of a quality difference.

1 Like

@Douglas_Gardner your last answer is very interesting and I have been tempted to open a new topic in a different section but … I found this one SOLVED: Is USB audio quality resolved with the Raspberry Pi 4? i.e. No need for SPDIF Output HAT's
It’s really too long (for me) to be completely followed but… it’s a community and it’s good everyone can say what is thinking. I also found your position in it.
Digital world is interesting but there are too many options and variables to be sure to understood it reading opinions without the knoledge of the system used to do listening test.
Better is to involve some good friends at home, play music, change the possibilities and have fun together discussing of “tis is better” or “this is bad” with a cup of good coffee or tea :grinning:

I followed a number of these threads while mulling over buying a couple of headphone setups for the study and living room (I was using the NUC originally to drive a headphone DAC/Amp)

In the end I went with Pi4, some audioquest jutterbug adapters, iFi power supplies and decent audioquest USB cables. I was both surprised and really happy with the results. I had previously tried Pi 3 and given up on that.

But that doesn’t get you your SPDIF output without a Hat, but I think there are plenty of
These mini bridges on the market that should work inline and maybe cost about the same as a hat. I do not have any experience with them, but I have seen a number of threads in these forums and others for them.

Regards

Mike

1 Like