History STILL not working properly and now a new issue [Solved with update to Roon 1.5]

I’ve been having problems with the history not recording all the tracks I play…for over a year now. I get told it’s a known problem but the thing never gets fixed properly.

It’s been up to it’s old tricks again - which showed itself yesterday when I’d been playing tracks for 2+ hours, looked at the history it had recorded ONE track, the last one I’d played. And just now I’ve been playing some test tracks, go to the history to replay some of them and none of them are there. This is for my business, so it’s a pita when it wastes my time like this…

Come on guys. I started programming in 1983 so I get the sheer complexity of storing each track in a database…(this is sarcastic in case you wondered…)

And now I noticed a new thing. The “pecentage played” on nearly every track is showing 0%, with a few showing 5%. This is simply wrong.

I looked back and I can see that this issue started on 2-Jan (but that might be 1-Jan in USA)

I really like Roon but this nagging bug is getting old…

Please fix it.

And before you ask, no I only have one profile. One roon core machine and one roon remote.

…crickets chirping

Hi @bob_prangnell ----- Thank you for the post and sharing your feedback with us. The insight is appreciated and sorry to hear of the troubles.

To help us better understand this behavior you are experiencing may I very kindly ask you to please provide the following:

  • Please expand on your setup description using this link as a guide.

" One roon core machine and one roon remote."

  • Are you noticing this behavior on all of your devices, OR, just some of them?

  • Just to confirm, the tracks that are not showing up in history were tracks that were played for either 30seconds, at least a 1/3 of the way through, or to completion, correct? No looping, skipping around, etc?


Roon core running on Windows 10 64 bit all latest updates applied. AMD CPU, 8GB ram, etc. ONly running Roon and HQplayer.
Roon remote running on Windows 10 64 bit all latest updates applied. NUC. Only running Roon.

Yes, problem exists on both machines. Roon versions are latest, but this bug has occured for many months if not years. (If you don’t know what the latest version of Roon is, it’s 1.4 build 300). Problem also shows if you use iPad as remote.

Music is stroed in one folder on network drive (Synology NAS). Size of library : 5713 albums, 46180 tracks. History is 2 years 2 months old with 33529 plays, although there were many plays that went unrecorded by history.

Network is wired gigabit and unremarkable.

Right now it’s getting a complete joke. Last night played tracks for 5 hours, yes most were played to completion but only 5 tracks were recorded in the history.

As a long time software developer it seems to me that the right thing is do is ask me to log what happens on Roon core (HOW??) , wait until it doesn’t record a bunch of tracks, then send you the log and history files (HOW?)

btw I tried both 32 bit and 64 bit versions on Roon core machine, same result.

OK playing with it today; It was suffering the problem, but I found it would always put track in history if it finished playing naturally at the end of the track. If I stopped playback using “next track” or selecting another track from album or playlist, it would not add to history, even if 99% of the track was played.

I’m pretty certain that when it’s working OK, this doesn’t happen (ie it records all tracks, even if only a small amount is played). But when it goes mental like this, it seems to only record the tracks that finish (this even works if you position the track to almost-the-end and then let it finish.). So check what’s different between the end-of-track methods…

Also still recording 0% played even if the whole track was played.

Hi @bob_prangnell ---- Thank you for touching base with me and taking the time to answer my questions. Both are appreciated.

A few things continuing forward…

  • Is there anything unique about your setup such as the time zone settings on your devices?

  • If there is anything else you can provide us (procedurally speaking) that is triggering this behavior it would be very appreciated.

  • As per Brian’s response to you here a track is recorded into “history” if the following is true:

  • more than 30 seconds have played
  • more than 1/3 of the track has played
  • the track ended naturally–i.e. the seek position advanced all the way to the end of the track without user intervention
  • If the above is failing I would like to enable diagnostics on your account so we can have a closer look into this behavior but before I enable this feature would you please reproduce the following:

    1. Please play a track past the 30 second mark and note the time of day when it has failed to show up in “history”. Please also be sure to verify the name of the track that was being played at the time.

    2. Please play more than 1/3 of a track and note the time of day when it has failed to show up in “history”. Please also be sure to verify the name of the track that was being played at the time.

    3. Please let a track end “naturally” and note the time of day when it has failed to show up in “history”. Please also be sure to verify the name of the track that was being played at the time.


Questions: Time zone, just using local (New Zealand) time zone on all PCs.

As I noted, it’s currently “broken” so it’s only recording when the track ends. But I am certain that it doesn’t always behave this way, often it will work as it’s meant to.

OK here’s the results of the tests:

  1. Playing past 30 sec mark. Track Name The Suburbs, Arcade Fire. Length 5:15. Played to 40 second mark, then clicked Next Track. Time was 10:55am Track not recorded in history

  2. Playing past 1/3 mark. Track Name : Ready to start, Arcade Fire. Length 4:14. Played to 2:50, then clicked Next Track. Time was 10:57. Track not recorded in history.

  3. Play whole track, allowing track to end naturally. Track Modern Man, Arcade Fire, length 4:39. Track is recorded in History, BUT it shows only 0% played.

) Bonus test : skipping manually to near the end of the track. Track name : Empty Room, Arcade Fire. Started playing, then at 2 secs, moved play position to close to the end of the track. When track finished, it was recorded to history. (also shows 0% played). .

Another clue : This “showing 0%” thing has happened since 2-jan (or likely 1-jan in your part of the world).

Thank you for the follow up and providing the requested timestamps @bob_prangnell!

Now that I have the requested information I will be go ahead and enable diagnostics on your account. What this action will do is the next time Roon is active on your core machine a diagnostics report containing a set of Roon logs will automatically be generated/uploaded directly to our servers. I will confirm when the report comes in so you know we have it and then pass over to our techs for further analysis.


OK I just played the same tracks as before, in the same manner and it’s not recording in history unless track finishes naturally (so the bug is reproduced). I’m guessing that there’s a time screwup somewhere which is why it’s reporting 0% played.

Thinking about it, I’ll restart Roon on the core machine and repeat, in case your logging needs a restart.
First run timestamped around 11:30am. Seocnd one follows first run, after restarting Roon. Hope you got what you needed…

Thanks @bob_prangnell, confirming that the mentioned diagnostics report has been received and is with our tech team for further evaluation.

Once my report has been updated and passed back I will be sure to share the team’s thoughts/findings with you in a timely manor. Your patience is very appreciated!


Hi @bob_prangnell ---- Thank you for your patience while our team has been looking into this behavior.

Continuing forward, our techs have informed that they have been unable to replicate the mentioned behavior using a similar setup to yours and the gathered logs are not providing the team with anything conclusive. In light of these findings the team would like to try and isolate this behavior by having you perform the following troubleshooting exercise:

  • Locate your Roon database according to these instructions
  • Rename the entire Roon folder to roon_old
  • Relaunch Roon, sign in, and configure a new install
  • Leave this configuration in place for 2-3 days and try to reproduce the issue.

Looking forward to hearing your observations!

OK I have just followed the instructions (which were a little incorrect - when you rename roon folder, you now can’t run roon as it’s in roon_old folder. But you can reinstall)

Right away the history is working as it should. But I’ll leave for a few days and see.

So can you un-screw my database? It’s nearly 3GB. Actually all I really need is my history…

And my favorites. And number of plays would be good as I often use Artist view sorted by most played.

Hi @bob_prangnell ----- Thank you for touching base with me.

Continuing forward, just to make sure we are on the same page, with a fresh DB in place your history is functioning as expected, correct?

Furthermore, being as we were unable to reproduce this behavior on a similar setup to yours in house the team would like to analyze the DB having the problem. Could please send us a copy of the previously used DB (i.e “Roon_Old”) via dropbox for evaluation.


Sorry been busy. I don’t use Dropbox, but I have uploaded the database, zipped, to here:

[Removed by support after download]

It’s quite big, a few GB

Let me know if this is OK…

Cheers, bob

Thank you for touching base with me @bob_prangnell, confirming that the DB has been received. Again, many thanks.

Just to make sure that you and I are on the same page, the DB you provided is the one that was having the issue, correct?


PS: I have removed the download link.

Yes that was the one. Hope you can reproduce…

Great! Thank you for confirming that @bob_prangnell!

The provided DB has been attached to your ticket which is back in our tech team’s queue for further analysis. Once your ticket has been passed back I will be sure to share the team’s thoughts/findings with you asap. Your continued patience while the team conducts their evaluation is appreciated!