How can I erase Roon off of a drive in my nuc?


I am brand new to Roon, but have done a ton of research and am excited to get going. I have built a Rock out of an Intel nuc model number NUCi310FNH. I put in 16 g of ram, 128 g M.2 drive that is running the Roon core software and a Samsung 2tb SSD for storage. Everything seems great except I made a mistake loading the software in and need help fixing the problem.
I accidentally loaded the core onto the SSD initially instead of the M.2 drive. I have since, removed the 2tb drive and reinstalled core on the correct M.2 drive and I downloaded the codec and the app and everything seems to be great. I have a bunch of music on an external 1tb usb drive and will connect that next, but I need to remove the Roon core OS from the 2tb SSD so I can now use it for storage. How can I do this?
Once I have that SSD drive installed in the nuc, nothing works. I’m guessing that’s because there are 2 versions on core running, or trying to run, on 2 separate drives. Can I simply erase Roon core from the SSD? Or reformat it to essentially a new blank drive? Thanks for any advice.

I think I tried that, but when both drives are installed I can’t seem to sign on via the web. Again, I’m very new to this so I very well could be doing something wrong. Can you give me a bit more detail on how to do this? Thanks again

If you are saying you can’t boot with the other drive installed?

You might try and verify the boot order in the BIOS to make sure the correct drive (M.2) is the one set to boot. I think you can also try this when booting by hitting an F10 key during boot and choosing the correct drive to boot to.

Also, you could install the 2 TB drive in another PC and reformat it, then put it back into the NUC.

1 Like

Yeah, sorry, i missed the won’t work when fitted bit - reformat in another pc, or change the bios boot order as Daniel suggests.

1 Like

I did go to the bios and make sure I booted from the M.2 drive and it still wouldn’t boot with both drives in. I’m not very computer savvy unfortunately and am not sure how to install in another computer to reformat. I appreciate the advice and will try and see what I can figure out. Thanks again

Try the F10 key during boot, it should bring up a list of drives to boot to.

So I tried F10 and made sure the nuc booted from the M.2 drive. It still would boot with both drives installed. This screen is what comes up and that’s it. I think I’ll need to get Roon off the other drive somehow.

Can anybody give some info how to fix this? Accidentally i installed roon operating system on my internal nuc ssd and i get exactly the same error as shown above, how can i wipe rock of my ssd?

Can you describe your setup in more detail.

You just need to access the bios, set it up correctly to boot off the M.2 SSD not the SATA SSD.
Instructions on how to do this can be found here.

Then install ROCK on the correct M.2 Drive.
Once installed you can format the Storage drive from the Web Console deleting your previous installation.

Thanks for the replies,

My system is a 10th generation intel nuc with ssd on the m2 slot and a 2tb internal ssd.
I will search for the specifics when i am home. Problem is rock system/roon system software does not start, so i cant format the ssd from roon system overview page. I try to start up, boot up from the m2 ssd but it does not work, i get the exact same error logs as the initial poster. How can i wipe roon of my 2tb ssd?

I dont have windows installed, the system is set up as a rock


The OP didn’t say how he solved the problem, but from his last post booting from the M.2 drive didn’t change anything.

If no one comes up with a better solution, you could always install WIN10 (you won’t need a purchased copy for this solution) on the M.2 drive. When WIN10 comes up, format the secondary SSD drive. Install ROCK on the M.2 drive, over WIN10, and you should be GTG. Then when ROCK comes up, format the second drive from within ROCK’s Web GUI.

1 Like

Fairly similar to above, disable or unplug SATA drive, use what ever install media you used to install ROCK to install again on the M.2 drive. Enter bios and set boot order correctly and remove the SATA drive from the bootable devices. It should then boot to the M.2 Drive and you’ll be able to format the Storage Drive from the Web Console. Shouldn’t need to install any other OS whether it be Windows or a flavour of Linux.

Have you actually done this and tested it?

Thanks all for the replies, its appreciated!
I disabled the ssd and started up via the m2 and it worked partially ( it still was not “seen” by all devices on my network but thats another issue). However because i had to disable the ssd i could no longer see it in the roon overwiew webpage so i couldnt wipe roon off the drive. When i re-enable the drive it fails to boot just in the same way as before. The problem still remains how to wipe roon from the drive. Any suggestions? Thanks

To be clear i could access everything in the roon overview page but because the ssd was disabled it was not shown

This will work. You don’t have to buy a copy of Windows to temporarily install it for this purpose.

Try it, unless you’d rather fumble around trying other things that don’t work. It’s up to you. :slightly_smiling_face:

Or move the drive to a different computer and wipe it.

If not handy already, it’s cheap enough to buy a USB-SATA adapter, use another computer with it and that drive attached to format it … where’s the problem?

No need to disable the SSD. Boot the NUC with keyboard, monitor, and ethernet connected. While booting, press F10 and select to boot from the M.2. After booting has completed, open the Roon webpage on a browser from another device, and it should allow you to format the SSD.

1 Like