How can I get rid of extra composers and performers?

I have a beautiful HiFi Rose RS150 with a super nice large display. I use JRiver for all my tagging needs. On a lot of my music, particularly Jazz, I just want it to show the main artist. Ex. John Coltrane not John Coltrane/Oscar Hammerstein. Some tracks even show sometimes 3 and 4 individuals. None of this info is in my tags. I know it comes from track identification within Roon.

I am not referring to photos. I am referring to ‘now playing’ status showing more than just the main artist listed. Some tracks show not only the main artist but other performers or composers…

It’s just annoying to me and I would like to get rid of these extra individuals. Is there a way? What is the best method? Thank you all for your time…

Hey @Michael_Green,

You have two options here:

  1. You can prefer to use your file tags for Album Artist for your entire library. If, as you say, none of the info you’re seeing appears in your local tags this is the way to go. (Settings>Library>Import Settings>Metadata preferences for albums>Album artist>Prefer file)

  2. You can prefer to use your file tags for Album Artist on an album by album basis as you discover these during playback (more labor intensive)

This album begins to play and you notice the above.

On the album page press the ellipsis button>Edit>Metadata Preferences>Album Artist>Prefer File>Save

I have everything set to ‘prefer file’. Even before import. I still get stuff that appears when playing a file that is not in my tags anywhere…

Can you post a screenshot the next time this happens and your album settings for that title? Also, just want to say again that the setting is ‘prefer file’ as a remind that Roon doesn’t always defer to tags if it detects some problem in the file tagging.

My tag does not have Johnny Burke anywhere in it. The Artist is Ahmad Jamal. Johnny Burke is a composer on this track and it is probably showing up here because of Roons identification of the album. However, I only want to see Ahmad Jamal. Sometimes tracks have 3 and 4 people listed…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hi @Michael_Green,

Are you preferring your own tags for this album/all albums? Can you share a screenshot of your Composer tags for this selection?

Yes I am. I set it like that before import.


Thanks for your reply. I have Roon set to ‘prefer file’ on everything. I set it up that way even before import. I just want to see main artist and how I have it tagged. I have tagged under artist and album artist ‘Ahmad Jamal’. No where in my tags do I have Johnny Burke. Why would this appear?

In this one… I have it tagged ‘Bill Evans’. No where in my tags do I have Ira Gershwin or DuBose Hayward.