How can I modify BIOS on Intel NUC7i3BNH running ROCK

Had this issue with my NUC ring was blinking blue. Then I tried accesses the BIOS. Tried a CMOS wipe. Turned ring to solid red.

Did a BIOS update still solid red. Roon still runs fine but F2 does not work in gaining access. Any suggestions?

google the NUC model and boot key sequence options

Michael you were lucky this was picked up so quickly. If you have a problem the support category is monitored more by the roon team. Handy hint :slight_smile:

Thank you, for your suggestion. The best option seems based on disabling a secure boot sequence. I do have access to the commands F2, F7 and F10 however these function keys (using wired keyboard) do not respond. I will try again this time first attempting to disabling a secure boot.

Appreciate your help. Stay safe.

Disable Fast boot if it is on.

I did disable fast boot. My nuk is a different model. I was able to use a use a hold the start button to disable the fast boot. I was still not able to access the bias setup. Haven’t tried disabling secure boot yet. Thanks for your help.

Not familiar with getting my question in front of support. I’ll try to release the secure boot and see how it goes. Thanks.

Well, I will move this thread to the Support thread and add a notice @support.

Thanks all you for the help. Going to show my rig one of these days. Got a vintage gear I repaired and customized, new rig tweaked and outdoor setup.

Hi @michael_stallone,

I’m not certain I understand what the issue is here, if Roon is working as expected, what are you trying to change in the BIOS? This sounds like an issue with your NUC BIOS itself, not the Roon component on it.