How Do I Cast to My Google Devices?

I’m listening to Roon presently on PC and I’d like to “cast” to my Google Devices. However, I can’t figure out how. And I see this screen when I try to group “zones”.

Group them in the Google Home app first then stream to that group in Roon.

Chromecast devices only allow grouping from within Google Home. Group them in their, Roon will see it a s grouped device and you can add that.

In roon go into Settings—>Audio and make sure the devices you want to send audio to are enabled.

I have the groups created in Google Home already as I’ve previously cast to them (from other apps). Roon sees them but I can’t stream to them from Roon.

When you say it won’t play what are you trying to achieve ? Are you trying to group them with some other non Chromecast devices as that wont work out as you can only group like for like protocols, or you trying to group together existing Chromecast groups or just play to one Chromecast group?

Your ‘Group 2’ is a single IP address. Not a group.
Have you clicked on the Group Zones icon on the top right of your screen shot? That will bring up a list of devices you can add together to a grouped zone. Anything playing to one will play to all.

Good question. I’m trying to play on my PC and also send it out to my Chromecast devices (Home, Max, etc.). I’m guessing that since my PC is not a Chromecast device then it cannot be used to send the music to the Chromecast devices (or be grouped with them).

So, if this is the case then I assume that if I’m using the app I would be able to broadcast to those devices (and my PC would not be included). Right?

@grossmsj That group with the single IP is a Chromecast group (not a Roon group). I thought Roon would be able to send music to Chromecast groups but it doesn’t look like it works that way (at least not when being sent from my PC).

You are correct that Roon can only group zones that share a common communication protocol. So something using only Chromecast can’t be grouped with RoonReady zones.

In your post I only see a single IP address for Group 2. I might not understand what you’re doing (wouldn’t be the first time).
A test would be to select a few of those Chromecast endpoints as a group. Try clicking on the Group Zones icon and click those endpoints, then play to the zone or endpoint in that zone.

I think I’ve got it now. @grossmsj what you’re saying about the common protocol makes perfect sense. My PC isn’t a Chromecast device so that wouldn’t work.

Now, I have a Chromecast Audio that I’ve connected to my PC (in essence making it a Chromecast device). Now, if I choose “Group 2”, Roon broadcasts to all of my Google devices and the Chromecast Audio that is connected to my PC. So, then my PC can play the music. What’s different in this scenario is that my PC isn’t the one sending out the music (by playing a FLAC); the music is being streamed to my PC by Roon. Make sense?

That doesn’t work for Google Cast devices. My typical Roon environment consists of different GCC’s only – GROUP ZONES is greyed out/non functional. You have to use the Google Home app to group Google Cast audio devices as documented in: Chromecast

Roon supports grouped playback on audio-only Chromecast devices via the Google Home app. Using the Google Home app, you can set up groups of devices, which then appear as additional audio devices in Roon alongside the hardware devices. So for example, you could group a few Chromecasts into a “Whole House” or “Living Room + Patio” zone, enable them as separate Zones in Roon, then play to them freely. Note that video Chromecast devices cannot be grouped together in this manner.

Due to hardware limitations, Chromecast devices can not be grouped with other, non-Chromecast devices outside of the Google Home app.


If only I had read that earlier. LOL.

One often hears a lot of forehead slapping after @BlackJack posts. Its a great combination of knowledge and clear, direct communication!