How do I copy music from my NAS directly to Nucleus internal HDD

I am helping a friend to setup a new Nucleus. The Nuc has an internal SSD disc onto which I want to copy music from a NAS, which is connected to the same network as the Nuc. I want to do the copying from my PC (Windows 10) and NOTvia the Roon app.

How do I get all 3 units connected?

You should see the Rock device on the network in Explorer and then you can navigate to the storage drive, as for the nas if the folder is shared on the network then you can mount it on the pc as a network drive then simply drag and drop the files as required.

It is not visible in Explorer. I tried several options but it won’t show…

Is that the Nucleus or the NAS?

Are you able to ping the IP address of the Nucleus and the NAS from the PC?

What os are you running on the NUC. Sorry I assumed Roon’ ROCK os.

The NAS is visible since I use it daily. The Nucleus is not visible at all. How do I ping?

It is the standard OS that came preinstalled with the Nucleus… I don’t know.

Ok so you have the Roon Nucleus running the Roon ROCK operating system.
Can you see the nas in Windows Explorer? If so have a read of the following to resolve Windows not seeing Rock.


GOOD NEWS! I figured it out. Posting the solution here as I’d be shocked if this didn’t come up again multiple times in the future with new ROCK builders using Windows 10:

In the Fall Creators Update for Windows 10, Microsoft disabled SMBv1 by default as they consider it insecure. This is how the ROCK exposes itself on the network, so SMBv1 is needed.

It’s very simple to enable again. Scroll down to the third post here (second reply): 35

Have you tried following the setup/discovery procedure listed in the Nucleus manual?

That’s the first step to do before you do the data migration step…

2 posts were split to a new topic: Unable to copy music from a NAS to the internal HD on my NUC

Open the command prompt window and type


Eg ping

Alternatively install a network sniffer application like fing. It will scan your LAN and list the devices it can find.

Hi @Jaan_Warnhoff ---- Thank you for the post and sharing your feedback with us. The insight is appreciated and my apologies for the delay on my end.

Please do correct if I summarize any of the above information incorrectly but as it stands currently, the mentioned NAS can be accessed without issue on the Win10 PC you noted in your report. However, the Nucleus can not be accessed over the network from the PC and as such you are unable to copy any music onto the the internal SSD installed in the Nucleus, correct?

I agree with the suggestion made above by @Carl, that you should try to either ping the IP addressed being assigned to the Nucleus from the PC using the provided procedure or loading an application like FING on the PC to scan your network for devices. This will be a good starting point in troubleshooting this behavior :microscope:

Additionally, if you were to open a web browser of your choosing and type in the IP address of the Nucleus are you able to successfully reach the devices Web UI?


Hi Eric,
Yes, your summary is correct. I tried to access the Nuc by entering the IP address, but then a dialog box came up asking for userid & password… Wonder what those could be…

Anyway, I use an app called Net Analyzer with my iphone and that app will scan all units connected to a router. It will show the PC, NAS and the Nucleus so they are all connected, but the Nuc cannot be accessed

Hi all,

Problem solved! I had to activate smb1 in Windows and now the Nucleus is visible in Windows Explorer.

Thank you for all good advice!


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.