How do I get help for ARC?

Roon Core Machine

Nucleus Plus

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Cannot get ARC to work. Ready to take unit back. It should not be this hard.

Happy to pay for an expert to set this up. Just want it to work!!! Please help!!!

This is the place to get help. Please tell us:

Networking Gear & Setup Details

Your router make and model, and the internet modem if you got one from your internet service provider.
Any other networking gear like any network switches.

Your internet service provider

Who delivers your home internet

ARC error message

From the Roon app > Settings > Roon ARC. There is probably a technical error message in the box top right, and there is a copy button next to it. Copy it and paste it here.

We have Fibre Optic NBN to the Premises through ‘Aussie Broadband’ as the provider.
Straight from provider to first Wi Fi Router D link DSL-5300 Dynamic IP network . We then have extender routers x 2, D link COVR-X1870 IPv4 Network.
ARC error message:
{
“ipv6_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“121.fff.ggg.fff”,“actual_external_ipv6”:“fe80:aaa:aaa:aaa:bbb:ccc:ddd:eee”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“>\r\n <s:Body>\r\n <s:Fault>\r\n s:Client\r\n UPnPError\r\n \r\n <UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\r\n 718\r\n ConflictInMappingEntry\r\n \r\n \r\n </s:Fault>\r\n </s:Body>\r\n</s:Envelope>\r\n”}
}
Thanks heaps. Very frustrating.

@Mark_Bastine, it appears Aussie Broadband uses CGNAT to conserve its small pool of public IPv4 addresses:

https://www.aussiebroadband.com.au/blog/what-is-cgnat/

https://www.aussiebroadband.com.au/help-centre/internet/port-forwarding-and-cgnat/

Unfortunately, Roon ARC currently does not work over networks using CGNAT. You may be able to obtain a static IP address from Aussie Broadband which then mitigates the CGNAT limitation for ARC, or possibly use the Tailscale VPN service for running ARC on these types of networks.

Edited title from “How do I get help?” to “How do I get help for ARC?”

Hi Robert, Thank you so much for your response. It is really, really appreciated.
I have gotten a Static IP from Aussie Broadband now. Can I please ask what is the new step?

Thanks again.

Check in Roon > Settings > Roon ARC if it says “Ready”. It may have started working on its own. If not, click the Copy button next to the error message in the box, top right, and paste it here.

1 Like

Hi Mario. Sadly, not yet.
{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“ipv6_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“144.hhh.iii.jjj”,“actual_external_ipv6”:“fe80:aaa:aaa:aaa:bbb:ccc:ddd:eee”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“>\r\n <s:Body>\r\n <s:Fault>\r\n s:Client\r\n UPnPError\r\n \r\n <UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\r\n 718\r\n ConflictInMappingEntry\r\n \r\n \r\n </s:Fault>\r\n </s:Body>\r\n</s:Envelope>\r\n”}
}

@Mark_Bastine, the diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. Is your DSL-5300 configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

You have two routers in your network, the DSL-5300 and now the X1870. Which router, or do both, do you use to serve your home network?

It should also be noted that Aussie Broadband support IPv6 and it is automatically enabled by default: https://www.aussiebroadband.com.au/help-centre/internet/does-aussie-broadband-support-ipv6/ but you will have to make sure IPv6 is set up on your modem/router.

https://www.aussiebroadband.com.au/help-centre/internet/configuring-your-router-for-ipv6/

I don’t actually know if ARC works with just IPv6 on Aussie as I haven’t played with it since I set up IPv6 on my router.

Initially I had the CGNAT issue with AussieBB but I called them up and asked to opt out, after that you need to wait an hour or so and re-boot your modem/router. Also I set up a port forwarding rule on my ASUS router and turned off UPnP.

Hopefully some of this will help you out @Mark_Bastine

1 Like

Also the DSL-5300 doesn’t need to be in Bridge Mode, the NBN connection box should connect directly to the Ethernet WAN socket on the back of the DSL-5300. The modem part of the DSL-5300 does not need to be used at all. I think @Mark_Bastine is already aware of this. It should be already set up in Residential Gateway mode.

@Mark_Bastine how is your Nucleus connected to the network? You really want it connected directly to your DSL-5300 via ethernet.

@Mark_Bastine here is a link to the DSL-5300 manual: http://files.dlink.com.au/products/DSL-5300/Manuals/DSL-5300_A1_Manual_v1.11(WW).pdf

Setting up Port Forwarding can be found on page 73.

If you live is SA I may be able to help you.

Still no luck.
{
“ipv6_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“144.hhh.iii.jjj”,“actual_external_ipv6”:“fe80:aaa:aaa:aaa:bbb:ccc:ddd:eee”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“>\r\n <s:Body>\r\n <s:Fault>\r\n s:Client\r\n UPnPError\r\n \r\n <UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\r\n 718\r\n ConflictInMappingEntry\r\n \r\n \r\n </s:Fault>\r\n </s:Body>\r\n</s:Envelope>\r\n”}
}

Hi @Mark_Bastine ,

Thanks for your message here.

This looks like something else is already using that port mapping range. Can you try a different port range in Roon for the ARC connection and also change the port forwarding in your router?

@Robin_Forrest, if you are needing assistance with configuring Roon ARC, please create a new support request so as not to dilute Roon’s ability to support the OP.

This is a bold statement and in such not valid for all CG-NAT deployments

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.