How do I get Nucleus to see my drive and music folder?


(James Cortez) #1

Hi. Purchased a Nucleus and KEF LSX speakers. Both are connected to my router.
My 4tb G External HD has my music folder and is formatted Ex-Fat and connected to Nucleus via USB
I moved my Core from my iMac to the Nucleus. I am logged in and see my Tidal music, but nothing from my HD.
Roon storage settings shows the path but says ''drive not available, check drive or edit this folder"

How do I get Nucleus to see my drive and music folder? And when I do, how do I add music to it? If the answer is sharing the drive on network, how do I do that exactly? Big reason I bought the Nucleus was it was supposed to be ''plug n play" but for me it hasn’t been. I need some help and appreciate any and all info and help. I’ve read thru all these support articles but nothing is working. And yes, I rebooted the Nucleus and still can’t use the ex hd.

THANKS!


(Geoff Coupe) #2

When you say “moved your Core”, do you mean that you’ve taken a Roon database backup that was made on your iMac, and restored it into the new Core that is now running on your Nucleus?

If so, the restored database will contain the storage settings from your iMac (where presumably your 4 TB external HD was previously attached). These settings are now no longer valid, so you need to edit the storage path to point to the new location of the HD, i.e. attached to the Nucleus. I think that this is what is going on…


(James Cortez) #3

Hi Geoff and thanks for responding.

yes I used a Roon database backup according to the support document. I get what you are saying but in Roon Settings the path is: Nucleus-GDrive-Music Folder so would that not be correct? My other drives that Roon used on my iMac I had disabled and they show now (still disabled) as Nucleus-Mac-Users-Music-Folder. So, I’m confused.

When I choose ''edit this folder" then ''browse" I get a blank window with no drive to choose from ? At the bottom left in that window there is an option to ''add network share" and a window pops up but I have no idea what info to input. ???


(Geoff Coupe) #4

Can you share a screenshot of the top-level Settings Storage screen? Thanks.


(James Cortez) #5

Sure. Here you go.


(James Cortez) #6

I mean if it shows the drive as connected to Nucleus, why is it not available?

Also, when I try to add a folder I get a blank screen. Attached photo.


(Geoff Coupe) #7

Hmm, I’m not a Mac user, so the answer is above my paygrade. I just wonder if this drive was previously used on the iMac whether there’s an access issue here… Let’s flag the Support team to help you further: @support


#8

Does your USB-drive have any lights that signal activity of the drive? If so, do they light up when you connect the drive to the nucleus?


(Mark Hyland) #9

@James_Cortez if you have a spare thumb drive, put a couple of albums on one and plug into the Nucleus, then add it. If it shows up with music, you have an issue with your main drive, possibly incorrectly formatted.
I own a Nucleus and quite simply I don’t think I’ve ever had a piece of hardware that was as “plug n play” as the Nucleus.


(Dylan Caudill) #13

Hi @James_Cortez — Apologies for the trouble here!

Have you tried using a different USB cable to connect the external drive to Nucleus? If you connect the drive to a different machine, like your Mac, does it show up properly?

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. I’ll be sure to let you know as soon as I receive their feedback.


(James Cortez) #14

Hi. Yes. It is lit up


(James Cortez) #15

Hi Mark. Ok I will try that right now. The G drive is brand new and worked on my Mac yesterday when I added music to it but will try a thumb drive. Thanks


(James Cortez) #16

Hi Dylan. Haven’t tried a diff cable, but the drive is brand new and worked on my iMac yesterday when I connected it for the first time and reformatted it to Ex Fat, then added my music folder.

I will try connecting to my mac again and make sure, and also try a thumb drive to the Nucleus.

Thank you!


(James Cortez) #17

Well guys, I think it’s a cable issue. I plugged the G HD into my Mac and it is said ''thunderbolt accessory will not work on this Mac" or something like that. It is a thunderbold drive, but I used the supplied USB cable to Nucleus, then just tried it to my iMac to no avail. Still weird that it showed in Roon as a path? It is a G-Technology 4tb TBolt drive. What can I do? It’s brand new. Ugh. Thanks so much again everyone.


(James Cortez) #18

the music on the thumb drive is showing in Roon. So do I need a new HD ? Or ?


(Dylan Caudill) #19

Thanks for the update, @James_Cortez!

As noted in our Nucleus Manual, the Thunderbolt drive is not currently active on Nucleus. For external drives, one of the non-Thunderbolt USB ports must be used. Apologies for the inconvenience here!


(James Cortez) #20

Ok I got it. Try different connections from G Drive to Nucleus and it is now scanning!! THANKS SO MUCH for pointing out my dumb user inflicted error!

Now, for another dumb question, do I have to unplug the drive from Nuc to my iMac to add music? I was under impression the drive would show up on my Mac?

You guys are awesome on this forum thank you


(Dylan Caudill) #21

Hi @James_Cortez,

Similar to Internal Storage for Nucleus, you can access the drive over SMB similar to internal storage, as described here.

Just enter smb://NUCLEUS/Data/Storage and you should be able to access the drives to add music.


#22

I had the virtually the same question/problem about adding files from my iMac. This is a reply I posted to someone else’s query:

The external drive that houses my library was Mac formatted (it was originally connected to a Mac Mini). I could “see” it, and the Nucleus OS, etc., on my iMac, but I could not move files in or out of the library.

Why? Because the Nucleus runs on Linux. So it does not speak to Mac formatted files. To make this work, I had to reformat my external HDD to FAT, which can be done in Mac’s Disk Utility program.

Of course, don’t overlook the indisputable fact that reformatting the HDD erases all files on the disc. That is why I keep at least three copies of my library files on separate drives (storage space is much cheaper than trying to replace lost files).

So, with the encouragement of Dylan at Roon support, I reformatted the drive, reloaded the library, and now I can pass music files in and out from my iMac. In fact, I will be loading 5.1 White Album files that way this afternoon so I can play the multi-channel music from my Nucleus.

Took a while to diagnose, but once the fix is in place, it works great.

Hope this helps!
MIKE


(James Cortez) #23

Hi Mike. Luckily I had reread the Nucleus manual and the links and I had reformatted the drive to EX FAT before I did anything. As stated above, I connected it wrong and it’s working now. Just need to try what Dylan suggested so I can add music to it. How are you adding the White Album from your Mac to Nuc drive for example. Thanks man!