How do I know the Nucleus is the Core in my system

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
I just received my new Nucleus and plugged it into the network and turned it on and just using my laptop installed Roon software to play music.

Is there a way to know if Roon is now the core or do I need to add something in settings. I just wanted to make sure the Nucleus is my core.


Go to Settings / General and it will tell you the Core the client is attached to. If it is still the laptop, click Disconnect, and then select the Nucleus from the Choose Your Core screen that pops-up.

Make sure your Nucleus in on, connected to the network, and that you can see it’s Web Interface from the laptop first.

1 Like

Hello @Gary_Walters, rugby is correct here. Also, if you need to move your previous core to the new Nucleus, you can learn about that process here. Please let us know if you have any further questions!

Ok I still cannot connect. The Nucleus is updated and I have two backup locations and they work as I forced backups. The nucleus does not show up on my network but my T+A streaming device does. should Nucleus show up on my network or not if it is just the Core?
Also when I click on Restore backups instead of logging in (to start nucleus in) their are no folders listed. I cannot find out how to get my folders listed in this step. It just says network path not found. I have folders listed for this but is their a way to copy and paste them? This is very frustrating to say the least and why did it just out of no where quit. I also noted the ip address is different from my router and I cannot seem to change it but the PC shows Nucleus as out there just cannot log in.

I should clarify that Nucleus is on my log in options on the PC…when I log in it says cannot log in check your network connection. EVERYTHING ELSE WORKS FINE ON THE NETWORK

Did exactly what Rugby said and wont log in :Check network connectivity is the response.

It sounds liike the Nucleus might have a static address, but that should only happen if it were a used unit.

The unit is 9 months old and this just dropped connectivity two days ago. Everything else including my end point streamer/dac works fine. Roon core connects to the pc fine also. I am having trouble with getting a named folder setup in the window screen via roon but my folders have been set up from the start and always worked fine and backup every 4 days. The machine intermittedly dropped out temporarily about two weeks ago and then just popped back on. I don’t think it is a connectivity issue with everything else working and I never touched any IP address settings from the start.
As new it connected fine to the network. It could be something with the latest software version 1.7.

Ok, not sure what you mean by this, then.

Tagging @support.

Well here is the final story of fixing this. I changed some setting…never did get figured out how to add a folder in the shared file. I knew what the downloaded files were but could never figure out the path the site wanted and I tried many time.
Last, I went and unplugged the router and connections…rebooted and then powered down the power trip second to a full restart of the network.
Finally Nucleus showed up in a different screen and I was able to connect. My music library stayed in tac but my audio setting were gone and i had to reestablish my Roon Ready device and redo the settings. It appears to be fixed but this seems suspect to issues so far in the 9 months of owning it. Granted I do not have the best connection but still averages 40mbps in the country.
I learned something again from this but this is the second issue in 3 weeks.
My eyes are wide open on whether this will work out long term or not. At least it is working again for now.
Thanks to those who reached out.
Best Regards,
Gary Walters

Hello @Gary_Walters, glad things are working again! Please let me know if you have any further issues.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.