How do I move my library to a new computer?

I just purchased a new computer and I would like to move my library intact from the old computer to the new one. how do I do this?

Hey @jstrouth – start here and let me know if you have any questions, or if you need some additional help.

If your storage location is changing as well, send me a PM so I can get some more details and walk you through this.


Hello, I moved my library from a Mac mini to a sonictransporter and I believe I mucked it up somehow.

All the tracks in my local (NAS) library are doubled up, and the first version of each track has a truncated pathname.

So the first version of a track always fails to play, but then when I get to the second version of the track it starts to play, then skips ahead. I’m having Tidal playback issues as well.

This is on different machines—playback on Mac and PC exhibit the same behavior. I tried disabling and reenabling the NAS path in Roon without any effect, and “cleaning the library” shows only 500 or so deleted tracks.

Any suggestions?

Hi @Jeff_Branion,
Did you checked your watched folder library path syntax ?
I’ve got the same symptoms on migration see: OSX to WIN10 migration issue: Truncated NAS library path? [SOLVED]

I’m moving from OS X to Linux. And when I try to add the \\[servername]\Music as a directory, it shows up in Roon as smb://[servername]/Music.

Hi Jeff,

Let’s drop a flag for @mike to check in.

As I understand it you are moving your Roon Core but retaining your music files on your NAS, is that correct ?

Did you take a backup of your database on the OS X machine before attempting any move ? It would be useful to be able to refer back to a known good database when looking at steps to get you fixed.

I would avoid cleaning up your library for the moment. That will update your library to the current bad state, which may not be the best course. If you have cleaned up your library, don’t panic, it may mean that Roon has to re-analyse.

Mike should drop in shortly to help out. My own experience is with Windows rather than OSX or Linux, so I think it better to leave you in his capable hands.

Sure, my similar experience ( OSX to WIN10 migration issue: Truncated NAS library path? [SOLVED] ) was also from OSX to WIN migration, not to LINUX …

Hey @Jeff_Branion – sorry for the trouble here, and the slow response. Can you post a screenshot of the Storage tab?

Can you tell me the exact steps you took to 1) move your database over to Linux, and 2) to set up your storage devices when you migrated over?


Ok. I’ve been out of town and unavailable, but I’m back!

So, here’s what I did:

Bought sonictransporter. Backed up Roon database from Mac. Secured the assistance Andrew at small green computer who helped me by copying over the database from the Mac to the sonictransporter. As I watched, he SSHed into the sonictransporter and copied over my music database. Once that was done, I had to go. A few days later, I (foolishly) continued without his help.

I started the server on the sonictransporter and connected. I started having the odd behavior described above, and because Andrew hadn’t finished yet, I figured I messed something up. So at that point I removed the database from the sonictransporter, then restarted. The database was still showing 3.0GB, even after I removed the database files from where I’d copied them. Uh-oh. I copied my clean Mac database again, figuring I could just have Andrew continue where he left off.

A few days later, I reenlisted Andrew and he continued the procedure he’d started. Not realizing I may have messed something up, he continued the procedure without knowing I’d already been further down the path. I didn’t mention it until I started troubleshooting it later. Andrew did some things with root access (I think he copied the files to another directory?) and then restarted the server.

Current status: I have two sets of “local” files, one with truncated pathnames. All my local albums have two copies of each track.

Typical track listing:

Truncated pathname:

Full pathname:

The first won’t play because of the truncated pathnames, and I’m just having a lot of playback problems in general, both with local files and TIDAL. Performance is terrible in general just navigating.

I’ve had a great experience with Roon up until now, and in fact I just upgraded to Lifetime. But right now I’m in a state where it’s useless. I can barely navigate, and I can’t play anything without sluggish performance and interruptions. I still have a copy of my Roon database from my Mac.

Storage tab, showing around double the number of tracks I expect:

At this point, if it’s impossible to recover, I guess I’d be fine to start over with a clean slate.

Hey @Jeff_Branion – I think we know the issue here, and we already have a fix in testing.

We’re hoping to get the fix live in the very near future, at which point this kind of migration should be seamless, but for now we are aware that some issues can arise when migrating network storage configurations to Linux (cc @agillis).

For now, you can run with a fresh, temporary database until the new release goes live, at which point you’ll be able to bring the OSX database over without issue.

If you have any questions @Jeff_Branion, just drop me a PM. Sorry for the trouble!