How do I stop Christmas music from playing

Is there a simple way to exclude Holiday music from coming up in Roon radio? This is a problem for my wife who likes jazz and vocals and it seems they pop up pretty frequently.

This happened to me the other night. If you give it a thumbs down, it will ask you why, and I believe that one of the options is that it is seasonal music (you may have had to say it doesn’t fit first, I am not sure), I don’t know if it permanently removes it from coming up again, but it didn’t happen again for me.

1 Like

Not seeing a thumbs up or down icon. Using smartphones for remotes.We have just been hitting the end of track button.

If you click on Queue at the top (next to Now Playing), it should come up on that page. But I am just seeing that on my iPhone, it doesn’t seem to give you the option to say why you gave it the thumbs down. It does on an iPad (and a PC), if either of those are options for you.

Went to Queue and removed those songs but I don’t know if that will have any effect. Doesn’t ask why you are removing it either.

I will try it on our tablet or PC thanks

1 Like

This should be happening automatically, but we can take a look.

What are clicking on specifically to start Radio? Knowing that will help us investigate. Thanks!

We leave Roon Radio on all the time so it picks up at the end of the selection. It seems to happen more when my wife uses Roon. Chris Botti, Kenny G, Josh Groban, Michael Buble are artists she sometimes starts with (they all have Holiday albums). I typically listen to artists who don’t have holiday albums so it’s never a problem for me.

Any solutions?

This just happened to me. I searched for New Orleans, selected the New Orleans Jazz genre, hit play. In the mix Roon has played Silent Night by Tim Fuller Experience, Dig That Crazy Santa Claus by Oscar McLollie, Jingle Bells by Leo Watson, Merry Christmas Baby by Lionel Hampton, Santa Baby by Eartha Kitt.

If I search for Holiday and select the Holiday genre, all of these songs are there.

I hope this helps.

Also does it if you pick Pop/Rock genre.

I just separate my holiday music into a separate base folder and enable/disable as needed.


I’m sure this works very well but it is not always practical. And it really should not be necessary, as Roon already knows which tracks are holiday music.

So do I but if you have Tidal/Qobuz that is not an option. Roon should be using the track Genre tag I believe to prevent these playing.

I also have Tidal and Qobuz…however, I haven’t had any random holiday music play via Roon Radio.
Luck of the draw maybe.

2 posts were merged into an existing topic: How to keep holiday music from playing in Roon Radio

Closing this old topic and have moved the reports, as the new report does not appear to be related to Roon Radio’s track selection.