How do I ungroup tracks?

Finally got that Roon creates a “group” (work) when subsequent tracks all start by the very same “something” followed by “:”

That’s usually fine, though here’s an instance where the wrong result is produced :neutral_face:
How do I fix it, please?

1 Like

I was going to ask the same thing. I’ve got a few albums like this, including the same one as you!

Though, I’m not sure it’s a metadata issue per se. Perhaps this would be better placed in a different sub forum? @moderators?

maybe should have been a feature request (ungroup compositions) but… it actually comes from file’s metadata

let’s hope developers see it nonetheless and come up with a fix :wink:

Yes, fingers crossed.

I see “metadata issues” as poor/incorrect metadata. The metadata here is perfectly OK, just that Roon’s interpretation of it doesn’t quite work in these cases :).

A manual ‘work’ ungrouping editor would be ideal for these situations.

1 Like

Hi Paolo and Mark,

I found this to be an issue with Roger Waters -Pros and Cons of Hitchhiking.

I personally think it’s a bug dealing with tracks that start with a time of day.

I’ll move it to Support and let’s flag @support to clarify whether they consider it a bug or not.

Cheers, Greg

1 Like

thank you Greg :slight_smile:

don’t think, though, it’s a bug: it’s rather a feature meant for Classical music where it actually serves a good purpose
but it turns up to be, on rare occasions, an issue with non classical

Could be a bug, but there’s a more general question (e.g. in classical) as to whether it’s right for some tracks to be grouped as a work, for example:

I’m not sure on this one, personally. Someone with more knowledge of Pärt’s music might chime in.

that one is right: “Two Lullabies” consisting of the Estonian and the Christmas one :wink:

Hi @pl_svn ---- Thank you for the report. I wanted to let you know that we will be looking into this behavior and once I have some feedback I will be sure to follow back up with you. We appreciate your patience while we investigate.



Hey @pl_svn – just letting you know that we’re aware of this issue, and there isn’t a way to edit this right now.

We are hoping to add this functionality in the future when we expand our editing functionality to include editing of compositions, but I don’t have a timeline to share here right now.

Sorry for the trouble!


thank you Mike

as I said, instances where this issue arises are very rare so… no rush :wink:

I would love to have the ability to ungroup tracks. It happens often enough to be frustrating that weird track grouping, imposed somehow on an entire album for example, prevents me from listening to individual tracks being played one at a time – for instance this is a problem in a playlist in which I want to shuffle the tracks with tracks from other albums, so there is one track from one album and then a track from another album. If there is grouping imposed on several of the tracks together of a CD I have ripped, or more frustratingly on the entire album, as is the case with several CDs that I have ripped, there’s no way in Roon to hear any of those tracks individually in a playlist on shuffle – you have to listen to the whole group, or the whole album, before it will move on to something else, which defeats the purpose of shuffle. Hoping we’ll have the ability to undo or deactivate composition grouping somehow in a future Roon release.

This has been resolved a while back.

While in the Album View, click the 3 dots icon and select Edit. Then click on the Edit Album tab. Scroll to the bottom and select Multi-Part Composition Grouping and click Disable.

Cheers, Greg

1 Like

Greg, apologies that I had not figured this out, but thank you! Fantastic, exactly what I needed. Greatly appreciate the response!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.