How do you transfer files off nucleus internal drive into another usb?

unusual question i am sure.

How do i transfer my music files off a nucleus internal drive onto another usb ? reason i ask is because the roon internal drive when i plug it via a usb adaptor to windows , windows recognises the drive but does not mount it so i can access the files in it. even when i go into disk management snapin - there is no option to mount the drive only to format it.

plugging another usb drive to the nucleus and then trying an export that way from the internal drive to another usb is dreadfully slow. >1 day to transfer 250gb

hope someone can help pls. did’t think it will be so dificult - will need to back off some files off the internal drive for the nucleus plus else i have lost it for good ( hope not)

i have a roon nucleus plus v2

I suspect that your problem is due to the file system on the external USB drive. Your Nucleus is a Linux device and it could be that it’s ext4 formatted and Windows can’t read it. How to deal with this depends on your tech knowledge a little.

ah cool. so how do i load a ext4 hard drive in windows?

Here’s a starter for 10:

Beware, this kind of software can lead to one or two issues and may well be read only. I’ve used ext2fssd it in the past and it was stable

cool:-) so i have an ext4 reader now i can see the files but the reader software wont let me copy it scross from the ext4drive to the ntfs dive i have - is there a work around?

Which software are you using?

ok…hit a snag…got the ext2fsd. assigned drive no to the ext3 drive ( roon formatted it in ext3) . used windows file explorer to open up drive and windows comes up with a msg that i have to format the drive in order to use it - still wont show me files in the drive

DON’T format the drive.

haha yup didnt do that:-) just cant copy files across. tried ext2explore but it cant find the drive. tried diskinternals but it wont let me load files in the drive as well…

What’s the situation with the NUCLEUS? I believe it supports network sharing to some degree. I’m not a ROCK user so it get’s trickier for me to help here. If you can share the drive and mount it as a network drive in windows you can copy the files. This article might help, but you may have started here:

Edit read a bit more and that’s not got the control you need. You could try booting a machine with a Linux live USB stick and accessing the drive that way. You could then copy to FAT32 (another file system) drive from that machine. Apologies I work from home but meetings will have me the next hour.

tried that too but the transfer is so slow 100-300kbps per sec and it drops to 0 kbps alot of the time as well . its extimating more than 1 day to transfer 250gb…bummer

Don’t do that; plug the USB drive into your computer and not the Nucleus.

Over WiFi? Try to use a wire instead.

Note: Using Windows to copy the files locally (with the help of a Windows driver for the Linux FS) can lead to difficulties later on as different OS’s might have differing ways of interpreting/writing metadata (timestamps, character encodings, …). If the metadata isn’t important for your use case you can ignore this.

using usd on windows s difficult - they cannot see the partition and using vaiours tools does not find the partition as well . at least i can see it is an ext3 partition now though.

not over wifi - that copy speed is the speed i get over the roon nucleus ports on 1 machine - its very very slow.excruciatingly slow

So you already use a wired network Ethernet connection then (between Nucleus and your PC)?

ah got what you mean now:-) ok so i have constant sppeds of 507kbps - better than before still 1 day

The slowest piece in your chain (Drives, USB ports, network) determines the achievable transfer speed.

gotcha matey:-) ok will work on it to see how i can get it to speed up:-)

Hi @Ian_Fok,

I wanted to check in with you here, did you complete the media file transfer successfully?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.