How fix conversion to max bitrate of 24

Ubuntu Server 19.10 fully updated running as VM in FreeNAS using latest Roon build

Wired connection to Rasperry PI3

RopieeeXL with USB Dac see below limited to 192/24

USB Souncard from AudioGD DIv3 that supports all samplerates up to 192 but only bitrate 16 and 24. Using Coaxial Output to amplifier.

Description Of Issue

I switched to Roon and would like to use DSP for Room correction and more, my problem is that a lot of output is upsampled to bitrate above 24bit. I bought the lifetime just this week, because I thought it was really easy to setup my hardware.

All music that is in any way converted and then send above a bitrate above 24 is not played by my DAC/Source from Audio GD. I found no way to limit the rate or force a conversion down to max 24bit, maybe because of the S/PDIF out limit of 192/24 bit?. The source is a nice piece of hardware with perfect quality, but the bitrate limit. It could be, that device does identifiy itself wrongly, because it offers I2S output that supports other rates?

I set the device to conversion to PCM, no MQA support nor DSD support.

My request for help:

  1. Is there any way in the Roon DSP to force max bitrate?
  2. Is there any way Ropieee to force bitrate to 24bit with USB and ALSA in use?

I searched the web for a few hours and did not find anything, besides the feeling, that Roon does NOT support bitrate setting just bitrate settings.

Any help and ideas are highly appreciated.

Best regards Klaas

Hi @Klaas_Reineke,

Can you share a screenshot of Device Setup, the current DSP settings that you have applied, and a screenshot of the Signal Path?

Wow, after opening the device Setup for the screenshot I saw the small “Advanced Settings” link. There I can set a max sample and bitrate and it works!

It should be more prominent at least for me :wink: somewhere in the manual or knowledge base I really did not want to post anything but did not find a documented solution for the max settings.

Now I have differenent problem in my setup. The music is just working if I set it to 16bit. Before switching to roon (last week) I had my own chain using brutefir convoler and 24 bit and it was working. This is strange, but maybe a different issue.

Hi @Klaas_Reineke,

Glad to hear this aspect is resolved.

Can you please share a these instructions of your Signal Path when there is 16-bit content playing?

Hi @noris,

These should be the right screenshots? I can throw everything out beside the samplerate conversion and it is still not working, if I have the device configuration above 16bit. I did try device configuration with maximum samplerate of 44.1 and bitdepth 24 and it was still not working. So I guess my device does not play well with something.

If you got an idea you are very welcome, maybe it is a new transport or HAT for my PI?

Regards Klaas

Hi @Klaas_Reineke,

When you say “still not working” what exactly are you seeing? In the signal path you sent, you started buffering 16-bit Qobuz content, which get converted to 64-bits for DSP operations and then back to 16bit for output. This is normal behavior when you have DSP turned on and you can read more about this in the following thread:

If you try starting playback of Qobuz 24-bit content, does it play as expected? If not, please clarify what exactly is going wrong because the signal path looks as expected to me.

Hi @noris,

not working is a strange beast: I hear nothing if i have bitrate > 16bit, but the amplifier sees 192 content, i.e. it displays that something is playing with the samplerate it receives. The amplifier does not show the bitrate of the content, only the samplerate. If I go down to a 16bit max, the amplifier produces sound. With the same hardware setup I could previously play content with 24bit as bitrate.

My main problem is solved, I am just baffled what the reason for this new behaviour is. My brutefir scripts where transcoding 44.1/16 into convolved 44.1/24 output without any problem. So the hardware was able to play 24bit content.

So if you have no ideas it is perfectly fine. It could probably be a hardware issue. But in the end the reproduction sounds great, so I am satisfied with the Roon setup.

All the best Klaas

Hi @Klaas_Reineke,

Thanks for clarifying this aspect. I wonder if the convolution filters are playing a part in this issue. If you disable all DSP, are you able to play 24-bit content straight through?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.