How to add more music files on NAS to the network share folder in Roon?

Roon Nucleus+ (Roon Version1.7 build 537)(Network Cable to Router)
NAS:QNAP TS-453Bmini
Router:MI Pro AC2600
Roon Bridge:Opera R8Pro(Network Cable to Router)

I have added network share folder.Because more music files were uploaded into NAS, I tried to remove the past folder and import updated network share folder to my Roon.But music files couldn’t be imported and only folder existed.How should I do next?
Thank you very much.

You don’t need to re-add the folder every time you add new music.

Leave the original folder in place and Roon will recognize that it has new music.

Sometimes, this can be a problem if the folder is on a NAS.
In that case, simply do a re-scan from this dropdown menu -

Why new files did not be added to the library after scanned files?

Roon can sometimes not pick up when new files have been added to a folder on a NAS.

If your files are on a NAS, then the best thing is to do a re-scan, as I showed in the post above.

Could I delete the network share folder and all the files in Roon?In order to re-add network share folder and files.

A post was split to a new topic: Roon not picking up new music

Normally, this shouldn’t be needed.

Hmm , then that’s a new problem.

I’m tagging @support for this.

Hi @Shaopei,

Just to clarify here - you added new music to the directory and that’s not showing up after a force re-scan? Are the files by any chance showing up under Skipped Files Submenu?

How to access this Setup interface?This option is not in the Settings in Roon.

It looks like network share fold has lost contact with all files.Scanning is OK,but no music is imported to the library.

Hello @Shaopei,

I’m not sure what you mean by setup interface. To access the Roon settings menu you can click the side-bar -> settings.

What does the current status of the share list as under Roon Settings -> Storage? Could you screenshot of what you see there?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.