[How To] - ARC with Synology 2600 Router in UK

your port forwarding isn’t working

I have been going through all the settings again. On the port forwarding rule, the Roon ROCK core is correct, the port is 55000 for the public and private port. I currently have the portforwarding set so an automatic rule is creating in the firewall.

I have a pi-hole on my system, could that affect things? I have tried switching off but to no effect that I could see.

The GRC test doesn’t care if anything is working on the inside, it just tests if the port is opn on the outside.

It’s an issue with your port forward rule or ISP

…… and/or the firewall rule

port forwarding bypasses the firewall.

I get exactly the same result if I try and use upnp as I do if I set the port forward rule manually.

What might an issue be with the ISP?

If your ISP is using CGNAT then it cannot then get through.
You might want to look at the thread on using Tailscale, as it will run directly on the Synology and give you access to ARC without port forwarding.

Very easy to follow instructions

(I would forward you the link but currently pulled off the road in my car)

change your port forward rule to port 80 tcp and try the GRC shields up test again using port 80 (or just click standard ports test)

Just had a look at the synology site and it may be that port forward is not integrated with the firewall (stupid design)

Try disabling the firewall on the synology and test ARC again

That’s not true. I own a Synoly router myself. On this router you have to do both: firewall rule + port forwarding rule.

With Upnp disabled, port forwarding on (public port 55000, private port 55000, TCP), generate firewall automatically checked, but then firewall disabled the core will connect! So it has to be a firewall issue right?? Firewall back up and I can’t connect again.

I deleted the automatic firewall rule (this rule was at the bottom of the rule set and I could not move it), and turned off the ‘generate firewall rules automatically’, I then recreated the rule and moved the new ARC rule to top of the rule set in the firewall and it will connect!! I need to read back up on rule order now to make sure I am not doing something stupid.


Thanks @ChrisRoon, @Alfred_van_Hoorn and @stampie for your help!!


Remember that the firewall rules are processed in the order of appearance. If for example the first rule denies a package the subsequent rules will never be processed.

Yes, thank you @Alfred_van_Hoorn. It was interesting that the automated rule was placed at the bottom of the rule-set and therefore did not work. Only creating a new bespoke rule and moving it higher in the rule-set resolved the isse.

Finally, I tested ARC today in the car, and it all worked great. Thanks again!

1 Like

I am in the UK and I don’t have a static IP, will that be an issue? I have just tried to set-up and get an error message which I thought pointed me toward setting up a port forwarding rule in my Synology router. However on trying this (with the same internal and external port defined in the app), I am still not able to connect, so I wonder if its the external static IP.

Please provide more info on your ISP and any other modems or routers on your network. The guys will then be able to help resolve the problem.

I’m using a symology router with a virgin media modem. I had the make sure the Vm Superhub was in modem mode and enable UPNP on the router to get things sorted

This is due to a double NAT issue.

It also helps to paste the error message you are getting in Roon Arc settings window.

Good luck

1 Like


Who is your internet service provider?
Please list the make and model of your modem and router?
Do you have any additional network hardware, like additional routers or managed switches?
Does your network have any VPNs, proxy servers, or enterprise-grade security?
How is your Roon Core connected to the internet?

Thanks @ged_hickman1 and @Stampie. I have another thread here.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.