How to can I import several composers at once correct?

Hello all,
I have noticed that when I add new music written by several composer, Roon doesn’t import them name by name but instead like this:

Composed by: Franco Battiano/Giusto Pio

That means that instead of Franco Battiano and Giusto Pio, those names are imported as one.
I know that I can change song for song in Roon… but that takes time, and the change is not done in the metadata in the original track.
The same goes if the metadata looks like this:
Franco Battiano, Giusto Pio
Franco Battiano-Giusto Pio
Franco Battiano; Giusto Pio

Does anyone know the way to make sure that Roon imports several composers in a song correct?

Maybe will work something like “Franco Battiano & Giusto Pio”?

Use supported tag delimiters; change/configure delimiters to your needs.

NOTE: We caution strongly against adding a ',' as a delimiter for Artist/Composer/Label tags. Many real-life artist names contain commas, and this will make a mess out of your experience in Roon.

PS: Keep in mind that unless you changed Roon’s import settings you most-likely see only metadata from third-party metadata providers for identified albums and not the metadata from your files.

1 Like

Thank you very very much,
I have solved lots of strange problems thanks to you @BlackJack

1 Like