How to delete from core some device?

How is it possible to delete some device from core in settings?
(Yes, I can use only one and I can turn “off” the others… but I have some “old” duplicates I want to delete!

I’m not sure about deleting but if you’re trying to stop certain devices from appearing in your output device choices you can go to Settings>Audio and disable them.

There was a bug a while back that caused this but I think it has been fixed. Rebooting the core is sometimes required to clear duplicates out. Might help if gave details of your Roon system.

Depending on where your core is you may need to disable or uninstall the device to get it to not show up.

Ok for disable… but I need to delete.

So, if I’ll do this, I’ll loose all my settings? (Rescan albums… live radio etc…)
ROON 2.0 (build 1133)

The core is inside my innuOS and the problem is that I can only disable not uninstall it…
This is the topic, I think.

Rebooting your core will not lose any settings. They are stored in the database part of the core.

If you do lose anything, then something is broken and you will need to do a restore from a backup.

Just to be clear, he said “reboot” which is just shutting the core device down (power it off) and then turn it back on (power it up). Not resetting the core. And as he said it would not loose any settings, etc. by just restarting the device.

1 Like

Thank you. I did.
Nothing happened :frowning:
(Always 2 devices online -it’s the same one- on ROON core, one I disable…)

I did, like you can read… but… nothing.

Please post a screen grab of the devices you are seeing and say which ones you don’t want please?

If they are devices on you network that Roon can see you can’t remove them only disable them. Roon will not stop seeing any endpoint it can play to in the audio settings section but you can just not enable them and they won’t show up as a device to play to.

You can’t delete what Roon sees if they are not enabled they are inactive. If Innuos is setup to be a core and endpoint you will see it’s options for outputting so if it’s connected to DAC that will ship in Audio devices as will spdif if you have the Zen Mini. There is no need to delete any device Roon sees as they just are ignored if not enabled.

Like you can see, the only ACTIVE is correct named “ROON Zenith…linux… etc”

The one I disable is THE SAME; on innuOS Zemith (Linux etc.) there is ONLY ONE core, of course.
But… still avaiable like an option!
(Before updateing to 2.0 was only one, plus of course the iPad…)

OK. Now… is (after the n-reboot!) OK.
I think some bugs between ROON 2.0 (build 1133) and innuOS (Linux) ROON core APP (2.02)
In fact…even QOBUZ (I have another topic open here!) does NOT stream over ROON even so, I am “connected” (on ROON settings) and I can see the QOBUZ library,
(With innuOS APP I can stream…)

P.S. (There are no info such as “Zenith…Linux… and ROON logo” you can see on the pict, now. Only “This is connected to Core”)

Looks like Innuos is running both Roon core and Roon Bridge as an endpoint. This is why two are shown One is the direct usb connections that the Roon core will see the other is Roon Bridge picking up the same USB connection. I would check in with Innuos as Roon Bridge is a separate process that Roon server does not start up. Something on the Innuos is triggering both to be running.

1 Like

Yes, with the new update (innuOS 2.0.x) you can choose -when selecting ROON as core- two options, including “bridge”.
But now, after some “reboot”, it’s OK. Only one is active and ready, even so no more info like ROON logo, IP etc. But it’s OK.
Thank you for your time.

→ Still crying for QOBUZ :frowning:

Have you tried logging out of Qobuz and then back in again in Roons Services section? Sometimes this helps with this. Make sure your using your email address and not username for qobuz login as they no longer support this for 3rd parties.

Or you can delete the Roon cache as this can also fix this type of issue, although not sure exactly where that lives on Innous.

1 Like

Well, like you can see, I am ON with QOBUZ ROON settings. In fact, I can make playlists and open library from QOBUZ… but: only when I press Play… the only thing I can get is “ERRORS”… and sometimes a popup window (on ROON) that inform me “not possible to log in”… even so… I’m logged!

I reboot everything: router… Core … innuOS… Roon… (quit and re-logged) but…
Even so… with innuOS APP (out of the core ROON of course) no problem. I can stream!

P.S. This is the topic… I don’t want to… use this anymore. Please if you have some time (thank you!) come here:
HELP_ no QOBUZ stream on innuOS

This is why I asked for you to log out of Qobuz in Roon then back in and see if it clears it for you. If not I am out of ideas

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.