How to disconnect from local files the right way?

Obviously ROON is not optimized for playing the local (itunes) library, it’s designed for streaming from Tidal. So what is the best way to have roon “forget” local files? Just uninstall roon and start over? Or some other way possible without having issues?

You can turn off the local folders under settings | storage…3 dots to disable or remove…the files wont be deleted just removing the link to the folder or disabling it.

1 Like

Roon is not designed for streaming from Tidal. It is designed to integrate and play your local files and/or stream from Tidal and/or Qobuz.

1 Like

No, we decided on another thread that its either one or the other that they interfere with each other. Just trying to figure out how to use with Tidal and not the itunes library

link? That’s totally misguided conclusion. The whole point of Roon is to manage all your sources into one library. It does do this well.

Anyway, yeah, just turn off the watched folder and those things go away.


One of Roon’s advantages is the integration of your local files with Tidal and Qobuz into your Roon library. I think maybe you haven’t totally figured out how Roon works.

Disable your Roon watched folder if you don’t want to use your local files.

The OP has a specific set up and needs that don’t really translate to Roon integration without a lot of cludging

We had a big discussion here on this forum a couple weeks ago. There is an issue where Roon always plays the track with the lowest resolution. And the only work around involves third-party software and several days of manual labor… I’m not willing to spend the time to manually program 50,000 tracks to play from tidal and not from my music library. I’m an audiophile and want it to play the high-resolution from Tidal and not the mp3s in my itunes library…

I always listen to the highest resolution Tidal or Qobuz offer.

Yes, but who wants to have to have an extra step of telling Roon to play from Tidal every time a song or album is selected? When i play from the Tidal App it automatically selects the highest resolution. However with Ronn it automatically plays the local file, which is always the lowest resolution…

It’s easy, one click.

That or I guess he could point the Focus on the local files, then when only these are shown, multi-select them and delete them. (EDIT: Note that this would actually delete the files, so copy them before doing it if you want to keep them)

Or a combination of both

This was all gone through in length on the other thread.

1 Like

EDIT EDIT EDIT - See @Rugby 's response below. We just did some testing and some of my info here is wrong. Roon will certainly select the higher resolution copy but, as pointed out, it absolutely needs to be added to your library from the streaming provider for that to happen. Additionally, removing a watched folder removes that album from your library. If that’s the only version in your library then you’ve removed that album from your library entirely until you add it back from a different source. Thanks Rugby.

I get it now but you’re really misrepresenting the issue. Albums can have various releases. The specific “best” album release can become a religious battle between friends. Chasing a specific release is a life long passion for some. With streaming we often have no idea exactly which of the various releases you’re listening to. In some cases the streaming company has swapped in a release we don’t like. It can be madness for those that care.

Roon assumes the local release is the preferred because its the one you own. It’s stable. It’s the release you painstakingly collected. It doesn’t care that this particular copy may be a compressed copy.

Others already explained how to get Roon to prefer the streaming version of the album. But… big but here…

It sounds like you don’t care what version of an album you listen to. You just prefer the uncompressed copy. In that case, you’re making the right decision to remove the “local” copy. Just go remove the watched folder. Problem solved.

But, using words like “incompatible” “plays lowest resolution” “interfere” etc. That’s incorrect and a misunderstanding of why you ran into this “problem”. I just wanted to point all that out in case someone reads this thinking they can’t run local + streaming and obtain an excellent experience.



  1. Roon will select the highest resolution for things in your library streaming or not.
  2. Just because you have a local album in your library, does not mean that Tidal’s version is in your library. You need to add it.

You can do that manually. You also might try to use Soundiiz. Once the Tidal version is in your library, then Roon will auto choose the higher resolution of content in your library.


I’ve been experiencing the opposite of this issue - if I search for a track or album that I have a FLAC of locally that also exists on tidal at the same bitrate/depth, roon will always select the streaming version. Not only this, but it does not recognize that I have the track/album, giving me the option to ‘Add to library’. It does not seem to be a metadata issue, as roon recognizes the album correctly when I am browsing via My Library.

Any insight as to why Roon does this, and how to avoid this behavior? It makes favoriting tracks a real chore.

Probably need to see a screenshot example of a local album doing this.

Click Versions and you should see it. Also, turn on “Show hidden tracks and albums.”

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.