How to Get Back Access to my I7 NUC based ROCK

I always start by going back to the basics and re-check everything. So, my first question, did you verify that everything (ROCK, one RPi device and a Windows 10 laptop) was plugged into the yellow LAN ports and not into the WAN port by mistake?

Yes, they’re in the right ports. Only the Intel i7 NUC ROCK can’t be accessed now. It was being accessed before the guy changed the DNS Server address to 8.8.8.8.

Is there some way for me to undo his change to a static IP address?

So he changed the IP address on the ROCK NUC from using DHCP to a static IP? So he must have used the ROCK web page to do this. If you know what the new, static, IP address is, then enter this into a browser to access the web page. There you can enter the DNS address used by the router. If you don’t know what the IP address is, you will have to attach a display to the NUC HDMI temporarily. That will tell you what the NUC’s IP address is.

It’s also possible that when setting up the static IP address on the NUC he has accidentally put it into a different subnet, which would be why you can now longer see it.

I’ve connected a screen. It reports that it can’t get an IP address. It doesn’t show up in any network scan. I’m not a networking expert, but I think that because he’s used an IP address for a non existent DNS server at a non existent IP address the device can’t get an IP address. Thus I can’t connect to it.

When it was working the screen would show the IP address assigned. But now it just says it can’t get an IP address.

What I need to know is how do I recover from this situation.

I’m sorry, but something doesn’t add up here. If the ROCK NUC is saying it can’t get a network address, then it must still be in DHCP mode. But you say that the network guy gave it a static IP address? How did he do this? Did he actually use the administration web page of the ROCK NUC?

That DNS Server address is the address of the Google DNS Server. It’s often used instead of the local ISP DNS Server, because it can be faster in some circumstances. I don’t think this is the root cause of your problem. Something else is going on.

The new Netgear V7610 modem on a different power point seemed to be more stable with the laptop and two RPi DACs running RoPieee staying connected to it. But the ROCK NUC would only stay connected for a couple of minutes and then disappear. We could access the ROCK via its admin wed page while it was connected.

The guy decided to change the ROCK to a static IP address. Saved the changes. Now the ROCK doesn’t get an IP address and I can’t access it at all.

The screen reports…
Searching for network address…
If this persists, please check your network connection.

The post Recovering from incorrect static Gateway/DNS Configuration? seems to have been a similar problem. It was solved but no details are given as to how when @eric asked.

Hello @Lloyd_Borrett,

Do you by any chance remember the exact IP address that the tech assigned the ROCK? If you have a screenshot or wrote down the exact IP assigned to it by the tech, it would be very useful in moving forward.

To get your ROCK back out of this state there are two options:

  1. You buy a USB to Ethernet adapter interface (such as this one) and connect it to one of the ROCK’s USB ports and connect it to the network that way and set the primary interface back to DHCP (A new interface will automatically be on DHCP).

  2. You setup a new router or change your router’s network range to match the same range as the static IP the tech gave it. Ex. If the tech set the ROCK’s IP to 192.168.50.124 then you will need to set your router’s DHCP address range to 192.168.50.1 - 192.168.50.254.

If the ROCK doesn’t show up on the network after doing one of the above steps, you may want to take a look at reinstalling the OS (https://kb.roonlabs.com/ROCK_Install_Guide) and then restoring your database from a backup (hopefully you have one saved somewhere safe).

Thanks,
Noris

I’m pretty sure he set it to 192.168.15.7

So if I add another Internet adapter to the NUC via this USB option, ROCK will ignore its current network settings, try to use the new adapter, get assigned a new IP address, and provide me with access to the web interface?

Unless the tech typed the static IP address in wrong, it should already be set to an IP address in the range of the modem 192.168.15.1 to 192.168.15.254, which is the same range that was used for the old modem.

I do daily backups to the external USB drive that the music files are stored on. So maybe I’m going to see how well the backups work. Is there a guide on how to restore a backup?

I’m late to this party and this has probably already been mentioned, but can’t you log on to your router software and find the address there?

To get to your router software type either 192.168.0.1 or 192.168.1.1 into a browser on any network attached machine. From there you should be able to see what IP is being used for ROCK.

This whole problem sounds like it might be an IP ‘collision’ between what was specified in ROCK and what is specified in the router.

I don’t have a Netgear in front of me now, but this two potential scenarios popped to mind:

  1. Netgear doesn’t use 192.168.15.0 as a base subnet number in any of its products, so unless that was changed in the router chances are you’re on a different network. Easiest way to check is to see if the computer you’re trying to access ROCK with has a 192.168.15.??? address.

  2. Most routers setup their DHCP pool starting at aaa.bbb.ccc.2 and then either use the entire range for DHCP or a big chunk of it. 7 is a pretty low number and depending on how many devices you have on your network the router may have handed it out to another device (at which point you have a conflict and strange stuff starts happening.

Oh, and as an aside… if you find that your ROCK is on a different subnet you don’t need to re-configure your router. Change the IP of your computer (static) to be on the same subnet. So with the address mentioned about pick something like 192.168.1.253 (should be safe) and enter that as your IP. This will allow you to communicate with the other subnet enough to fix your ROCK. Once done switch your PC back to DHCP.

Also there is absolutely no reason for ROCK to need a static IP on most (or any) networks. Due to the way that Roon works it doesn’t matter what the core’s IP address is or how often it changes.

Whoa… bad advice. If a device is assigned a static IP then that IP cannot live within the range of DHCP addresses or bad things will happen. In the example above (static at 192.168.50.124) then the DHCP range would be 192.168.50.2 - 192.168.50.123. Most consumer routers don’t allow for a split range of DHCP addresses so you have to start after or end before the static address.

The netmask defines the network so with 255.255.255.0 the subnet would be 192.168.50.0 through 254 regardless of the DHCP range.

If for some reason you need static IPs then they should be reserved at one end of the subnet or the other (or both with DHCP filling in the range in between). Regardless you NEVER EVER EVER EVER EVER want your static IPs to overlap with the DHCP range.

Sorry, unless I am misunderstanding what you said, I must disagree. I use static IPs for all my devices and I select them from the range of available IPs within the DHCP range. Without any problem.

Having said that, I know that pfSense (and probably others) doesn’t let one do that, for some reason or other.

Hmm, upon reflection you are talking about setting the static IP from within the device software? I set mine from within the router software. That’s probably the difference?

The problem is that the DHCP server has no way of knowing what addresses have been assigned statically nor does it do any checking before handing out an address.

If I have a DHCP range of 192.168.1.2 - 254 and I assign a device to 192.168.1.5 sooner or later (likely sooner given the numbering) the DHCP server is going to tell a client to use the same address. At that point arp breaks as two MAC addresses will answer when another device on the network goes looking for the hardware that corresponds for that IP address.

When this happens it’s typical to end up with a device that’s visible for a short time after it’s powered on, then it disappears and becomes unreachable.

There are also some really crappy IoT devices out there that don’t even implement DHCP correctly. They’ll get a lease but not renew it properly and at some point the server hands out that address again. Communication issues abound after that.

2 Likes

Ah… OK. That’s different. Technically that’s a DHCP reservation and not a static IP. In that case the DHCP server is never going to hand that address out except to the specific MAC address that the reservation is set for. This is the safe and clean way to do fixed IP addresses on a DHCP network.

Yeah, reservation is the better term than assignment.

I think we agree on another thing and that is that the OPs problem looks like an IP ‘collision’.

1 Like

Wish it were that simple. The modem doesn’t show the device. It shows the laptop, and the two RPi DACs, plus the iPad and Anroid phones, but not the Intel NUC ROCK.

The reason the tech wanted to make the IP address static was because he though the ROCK might be loosing connection because of a possible IP conflict. So he wanted to move it to an IP address that Angry IP Scanner and Fing both said were not being used.

I would have thought the way to do that would be to reserve the IP address for the ROCK in the modem first and then tell the ROCK that IP address, but that’s not the way he went.

This modem is built by Netgear specifically for Telstra and no doubt has a different software config because of that. The IP address of the modem is 192.168.15.1

The IP address of the laptop is 192.168.15.2
There’s a Galaxy S8 on 192.168.15.4
There’s a Galaxy Note8 on 192.168.15.5
The HiFiBerry DaAC is 192.168.15.8
The iPad is on 192.168.15.9
The Audiophonics DAC is on 192.168.15.252

I don’t have any way to find out what address or subnet the ROCK thinks it’s on. The on screen message would seem to indicate that it’s not being given an IP address by anything.

I know, and that’s what Roon support recommends. But a static IP address was tried because the connection to the ROCK wasn’t staying up for more that a few minutes.

Absolutely correct. This ‘tech’ really did a number on you, but I guess that doesn’t help.

This seems to be what was happening with the ROCK, which is why the tech wanted to try setting a static IP address. It just seems that setting a static IP address has not been done right so now I find myself with no access to the ROCK at all.