How to get RoPiee's previous release

I am a RoPieee beginner, does any one of you can let me know how to get back RoPieee’s previous release cause got noise after updated the latest release “2018/08/12 (148)”, so I want to get back to 2018/07/30 (142) to fix the noise

RoPieee does not support rolling back.
So what kinda noise are we talking about?

hi @Ellen_NG, any update?

Sorry for my poor English. How I can desribe those noise…seems…the sound “di di da da” when you play a dirty vinyl on a turntable.

My RoPieee is connected to MyTek Brooklyn DAC+.

Just read about a post subjected "Noticeable “pop” sound when playing song. I think those noise I mentioned, is “pop” sound during playing FLAC file.
I tried to sampling upgraded to DSD64 however those “pop” sound still appear, then I tired to play DSD file, I found that sound is stopping and starting often over a period of time, but not regularly.

my device connection is
network switch -----(cat6 cable)---------->to Pi3----(USB 2.0 cable)----->Mytek Brookyln DAC+

When I disable ESP Engine, it will become better, the “pop” still appear but become rarely.

Ok. So what kinda Pi3 do you exactly have?
And you’re saying that this didn’t happen in the past?

Regards Harry

Actually I ma a newbie and right now, using Pi3B+ with latest Ropieee, 20180812-reopieee-ose-stable. I never try the previous version before, Just wonder, should try the previous version whether can be fixed or not. or need to wait until another new version release.

Wait for the new version. I release it this week.
So you’re on a 3B+? That might be the reason for the clicks!

There’s a problem with the ethernet connection on the 3B+, will also be fixed in the upcoming version.

Regards Harry

1 Like

Hooray! Love to read this good news.

Looking forward to getting the new version.:sparkling_heart:

How are you planning to fix it? Restrict the port to 100Mb?

yes that’s the only option right now

1 Like

Thanks. I was going to ask if it’s possible to install ethtool in RoPieee and edit /etc/rc.local. I guess I won’t need it if you are going to implement this change.

I wonder how you are going to do it. I found that inserting the following into /etc/rc.local does it: ‘/sbin/ethtool -s eth0 speed 100 duplex full autoneg on’.

Whatever you do please keep autonegotiation on. Otherwise some switched may negotiate 100 half duplex only.

This is exactly the change that I made :slight_smile:


Updated the latest release(160) and found the noise “pop pop” fixed.
Thanks for your great job, Harry​:sparkling_heart::sparkling_heart::sparkling_heart::sparkling_heart::sparkling_heart:

1 Like