How to import 5000+ singles from NAS?

How to import 5000+ singles without an enormous amount of work by adding [Single] to each file name?

you can use mp3tag to add “[Single]” the the metadata field “track” and to the actual file name itself if you like. Can all be done in a single batch with a couple of mouse clicks. mp3tag works on most codecs, not just mp3 files.

  1. load up all the files you want to add this to in mp3tag.
  2. Select all these files
  3. In top menu select CONVERT, then choose “tag - tag”
  4. In FIELD select: TITLE
  5. In Format String enter: %title% ‘[‘Single’]’
    (note the single quotes around [ and ]
  6. The above changes the title tag field. If you want to also change the track name, use CONVERT then “tag - filename” and use a format string something like:
    $num(%track%,2 ) - %title%
    (or however you want your file names written…this is all programmable within mp3tag.
2 Likes

Good advice by @garym. I don’t know if this will automatically set the album type in Roon to “Single”, but maybe it does.

If it does not, you can multi-select all singles and go to the (…) button > Edit > Album Type and set to single. (If you import all of them in a batch, you may be able to multiselect them from Home > Last added. Else you would somehow have to filter for or focus on them, so that you can multiselect all together)

1 Like

Good point. I don’t think Roon would recognize these as singles unless he does your suggestion. And I suppose he could skip my suggestions and just do what you suggest. But of course this only changes it in Roon, and I’m one that likes to keep my tags, file names, folders, etc. up to date and tidy. :wink:

1 Like

And if it was me, I would also use mp3tag to add an ALBUM tag to all these singles called “Singles” or something similar. Of course do not do that if you have each song assigned to the album from which it came originally.

Thanks for your replies. I am familiar with MP3Tag.

It would be nice if I can add (meta)data with Mp3Tag to the song files which Roon recognises as “Album type Single”. Nothing worked so far.

I’ve tried in Roon to select a bunch of singles and edit (…) album type, but Roon does not respond in the same way as editting a single album. So I can’t set album type as single in a batch within Roon. (I guess)

Any options to try?

It happens that I make a fool of myself by saying something without being sure :slight_smile: but usually I try it out and this worked for me:

  1. Multiselect the albums, then click the (…) menu at the top

  2. Click Edit in the menu, then go to the tab EDIT ALBUMS

  3. Scroll down to Album Type and click Single, then Save